I designed a very simple 4*3 keypad system controlled by an ATMega32U4-MU MCU, using Adafruit's Itsy-bitsy 32U4 as reference (attached is the schematic of my circuit, while Adafruit's circuit can be found at https://learn.adafruit.com/assets/49818). There is a 16 MHz oscillator on board (FA-20H 16.0000MF10Z-AJ0) with 22pF caps.

To program the bootloader, I am trying to use an Arduino Uno set as ISP, using the following link as reference: https://www.designedbycave.co.uk/2020/ItsyBitsy-Bootloader/ Connections:

Arduino -> Atmega32u4 board 5V -> 5V GND -> GND 10 -> RST 11 -> MOSI 12 -> MISO 13 -> SCK

I tried burning bootloader using both Arduino IDE (set board to Itsybitsy 5V 16 Mhz and later on Arduino Leonardo) and WinAVR CLI (Caterina bootloader downloaded from https://learn.adafruit.com/introducting-itsy-bitsy-32u4/downloads). Both show the invalid device signature verbose error.

I was having similar problems with an ATmega328P board earlier, which I solved by connecting pin 10 of Arduino directly to RST pin of target board instead of DTR pin (many people suggested oscillator issues, connection issues, circuit issues, capacitor issues etc. but those were not right). But here, the RST pin is already directly connected to RST pin of the MCU.

I checked for circuit error and shorts but found none. Everything was electrically intact. I made three of these boards and all three have the same issues.

Kindly look into the schematic and suggest what's wrong. My guess is PE2/HWB pin needs to be grounded for the bootloader to load (the Atmega32u$ comes preloaded with a bootloader from factory so it should be detectable by the computer when connected via USB without requiring bootloader flashing, but this is not happening).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.