I've been at this for over a week now and still cant get things working. Im attempting to wire up an ESP-01 chip to a Nano to send AT commands over Serial. I've followed many different tutorials, but the best (and my current) setup seems to be this one:

https://www.youtube.com/watch?v=YKn2ZXYb_EI (Wiring) https://www.electronicslovers.com/2017/11/learn-how-to-setup-wifi-module-esp8266.html (Wiring & Code)

My breadboard has that exact wiring as shown in the video and the website. I understand that the 3.3v pin doesnt provide enough power, so I've used a DC Voltage regulator to step the 5v pin down to 3.3v, and I'm using that as my main power line.

When I plug the Arduino in, I get a quick couple of flashes from the blue light on the ESP, as well as a solid bright red light. The light is brighter than when it is directly from the 3.3v, so I'm pretty sure it's powered enough.

I then open Serial monitor and get no response when I type AT:

enter image description here

I have tried at both 9600 and 115200 baud, and tried many different wiring setups, all to no avail.

If someone could help with this I'd be forever appreciative

  • After taking some readings with my multimeter - I see the output of my regulated 3.3 rail drops to 2.55 with the ESP plugged in... Do I want to bring this up even more so it's 3.3 WITH the ESP plugged in?

  • I don't think the above edits suggestion will work since I've also wired the chip to a 3.3 breadboard power supply powered by a barrel jack - still no avail

  • I understand I can write firmware directly to the ESP-01, this is not my goal here. I require it as an add-on to the Nano, since I need its analog pins, amongst other things'

1 Answer 1


Wowwww i finally figured it out after a week of messing around, and 20 mins after posting my question.

To anyone else who stumbles across this: Please understand if you're following this tutorial here or here. There is a bug in the code:

SoftwareSerial softSerial(3, 2); // RX, TX

should be

SoftwareSerial softSerial(2, 3); // RX, TX

Also the suggested baud rate of 9600 doesnt seem to work, adjust to 115200 and go from there. Once you get a receiving signal, run the following to adjust the 01's baud to 9600:


After this, reflash your nano with serial bauds set to 9600 and you should be able to send AT commands over your Nano to the ESP-01 via 9600 baud

In addition to this. You will read online that you might be able to get away with stepping the Nano's 5v pin down to 3.3 to power the module. This didnt work for me, and i suggest you get a breadboard power supply

Good luck to all!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.