1

I'm trying to upload an simple blink sketch to my Arduino Nano, which not used for a while.

As I remember, I uploaded an sketch to control RF module, at the last time I used. Now, when I connect my Arduino Nano, I 'm getting error message every second, from my serial monitor saying the the RF communication cant start, because I have disconnected all connections to the RF module.

It seems the Nano is working, and the Nano driver is working properly. I tried resetting manually, and uploading many times with random timings. But up to now, the sketch not uploaded, and waiting. When I press reset button while uploading, Arduino shows me the error it cant communicate.

I think the Arduino IDE not getting enough time to upload from serial, because it's busy all the time.

Is there any way to wipe out the existing sketch from Nano? or any working solution to upload my new empty sketch or simple blink sample? It's a big help if anyone can shed me some light to make my Nano work again.

9
  • 2
    select "Old bootloader" in Tools menu – Juraj Oct 11 '20 at 13:18
  • @Juraj, I'm unable to find 'Old bootloader' in tools menu. You mean 'Burn bootloader'? – Ruwan Kumara Liyanage Oct 12 '20 at 7:38
  • @Juraj, Ok I found it on sub menu and worked great! Thank you so much. – Ruwan Kumara Liyanage Oct 12 '20 at 7:55
  • @Juraj I solved it thank you – Ruwan Kumara Liyanage Oct 12 '20 at 9:37
  • You should use the "That solved my problem" button, not write an answer – Juraj Oct 12 '20 at 12:57
1

I have solved the issue by selecting,

Tools > Processor > ATMega (Old bootloader)

@Juraj, Thank you for suggestion.

Not the answer you're looking for? Browse other questions tagged or ask your own question.