1

I am very new to arduino, so new that it is my first board. I keep running into this error
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
I have searched the internet for hours, tried solutions from almost every StackExchange question related to this topic, and even Reddit posts but none of those have been able to help me. All my settings are as they are supposed to be. Both the correct board and serial port are selected but it still keeps giving me this error:
System wide configuration file is "/home/rahat/Desktop/Arduino/arduino-1.8.13/hardware/tools/avr/etc/avrdude.conf"
User configuration file is "/home/rahat/.avrduderc"
User configuration file does not exist or is not a regular file, skipping

   ` Using Port                    : /dev/ttyS4
     Using Programmer              : arduino
     Overriding Baud Rate          : 115200`

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
Also my operating system is Ubuntu 20.04 LTS

6
  • You have the wrong port selected. It should be /dev/ttyACM0 or /dev/ttyUSB0 – Majenko Oct 8 '20 at 22:48
  • 1
    There are no ports /dev/ttyACM0 or /dev/ttyUSB0 available to me – Rahat Oct 8 '20 at 23:36
  • @Majenko the only port available to me is /dev/ttyS4 – Rahat Oct 8 '20 at 23:36
  • Then you either have no acess rights or hardware issue. Try lsusb. and post us an output. If it finds the hardware stating something like 'QinHeng Electronics HL-340...' (there are others). We will try to trace access issue. If lsusb doesnt see it then its most likely a cable, but other options are we will trace when it comes to it... – Tomas Oct 9 '20 at 2:36
  • in some cases you may have to use sudo lsusb – Tomas Oct 9 '20 at 2:37
2

First of all find out on which port the Arduino is connected by running the command : dmesg | grep tty. You should get [82893.921017] usb 1-1: cp210x converter now attached to ttyXXX with the ttyXXX COM port. Then check if the port is visible Tools->Port. If the port is not visible then you have a permission issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.