1

I am new so please be nice :)

I am trying to upload the Blinky example to my Arduino Nano BLE 33 but I get this error message from the Arduino IDE:

No device found on ttyACM0
Set binary mode
Send auto-baud
An error occurred while uploading the sketch
Set binary mode

Any idea what I could try?

I am running the Arduino IDE as superuser in Manjaro (latest versions of everything). If you need any more information please feel free to ask.

Full IDE output:

Sketch uses 77820 bytes (7%) of program storage space. Maximum is 983040 bytes.
Global variables use 42192 bytes (16%) of dynamic memory, leaving 219952 bytes for local variables. Maximum is 262144 bytes.
Forcing reset using 1200bps open/close on port /dev/ttyACM0
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
PORTS {/dev/ttyACM0, } / {/dev/ttyACM0, } => {}
Uploading using selected port: /dev/ttyACM0
/root/.arduino15/packages/arduino/tools/bossac/1.9.1-arduino1/bossac -d --port=ttyACM0 -U -i -e -w /tmp/arduino_build_408944/Blink.ino.bin -R
No device found on ttyACM0
Set binary mode
Send auto-baud
An error occurred while uploading the sketch
Set binary mode
7
  • try a double-reset and then upload – Juraj Oct 7 '20 at 15:10
  • are you being logged in as a root? – Tomas Oct 7 '20 at 16:24
  • if you are running as both user and root, the udev may have mapped device for user already, and as such is bussy with another process Try sticking to user and giving yourself sufficient rights. it is not a good idea to do too much stuff as a root. Well build modern distro (less then 10 year old should give you sufficient access without need to resort to un-safe practices). If you are on advanced user distro (eg Gentoo) see suitable Arduino How--to – Tomas Oct 7 '20 at 16:30
  • Send us a picture of: Tools->Port (or write options down) when trying to program. they would be something like /dev/<something><number> Although tell us if you are using wired or wireless programming – Tomas Oct 8 '20 at 2:54
  • @Tomas, the uploader output in Question shows, it can access the port – Juraj Oct 8 '20 at 5:48
-1

It appears you are using Linux. In order to communicate you must establish yourself as being allowed to use it, that is the dial out function. "sudo usermod -a -G dialout " should work but you need to log out then back in before it takes effect. After that you are all set.

4
  • 1
    I am not sure if he is using serial port or over Bluetooth as I am not sure if nano BLE supports over bluetooth programing. (otherwise the nano may be mapped to /dev/ttyUSB0 (number may change). While I appreciate that on ubuntu (Debian based Distros) you use sudo, but not all distros (I personally keep sudo disabled). Adding user to dialout group is only correct step on some distros and only for some form of programing... Better follow tutorial for your distro – Tomas Oct 8 '20 at 0:52
  • the uploader output in Question shows, it can access the port. for access rights settings on Linux I am sure we have an answer here somewhere so this would be a duplicate – Juraj Oct 8 '20 at 5:48
  • When trying to add the user to the dialout group I get this message: "usermod: group 'dialout' does not exist". However I am running the Arduino IDE as superuser so I should have sufficient rights. I am using the USB port of the board to program it. Unfortunately I have not found a solution for this problem anywhere. Thank you guys. – user69294 Oct 8 '20 at 8:06
  • I never run in supervisor as I can do a lot of damage to the system. Beyond this I cannot offer anymore help. – Gil Oct 9 '20 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.