3

Recently I started to learn embedded electronics and C/C++ and for a couple of days I tried and I am still trying to burn a new ATMega328P U bought from Aliexpress. From what I know new ATMega328P's come with bootloader included, but after I wired everything up and connected the FTDI FT232RL to load the sketch (wiring is completely right after many many hours of checking on the internet for a dozen of pictures), I get errors like "programmer is not responding" in case of sketch upload and "error while burning the bootloader" or "Yikes, signature bla bla". I don't think the FTDI is the problem since the Arduino IDE recognizes it as COM7 on my PC. Now here's my question: is my atmega328p u broken or have I missed something during the process of both (trying to) burn(ing) the bootloader and upload(ing) the blink sketch? (I have also tried uploading the board programmer from Nick Gammon on my arduino Uno and the burning the bootloader AND followed the instructions from arduino.cc "from arduino to microcontroller on a breadboard"). If you need pictures of some sort, I'll provide them

14
  • 1
    I don't have anything wired right now, but tomorrow I'll send some pictures here, errors, wiring and whatever can help Sep 28 '20 at 19:03
  • 2
    There is no such thing as an ATMega328P-U. There's the ATMega328P-PU or the ATMega328-PU - the former is what is used on the Uno, but it sounds like you have the latter.
    – Majenko
    Sep 28 '20 at 22:08
  • 1
    imgur.com/gallery/rAEq9kg Sep 29 '20 at 5:52
  • 1
    I am not sure if the tutorials vary from model to model. All I want to know is if there is someone who knows a method that is guaranteed to work for my model in the picture above. Or at least show me what is the problem in what I did. I really want this to work and reach higher and higher in knowledge of circuits and programming Sep 29 '20 at 10:46
  • 1
    So it results in the posibility of not being able to correctly burn the bootloader and work with it? (sorry if my questions are too dumb or "captain obvious" - ish, but I'm learning on my own) Sep 29 '20 at 11:37
2

IT WORKED, FINALLY. I followed this tutorial: https://www.electronics-lab.com/project/installing-the-arduino-bootloader-on-the-atmega328p-microcontroller/, followed exactly as it is explained, made the connections (nothing more, nothing less; I even removed the LED on pin 19 and its resistor) and to my surprise... the bootloader was actually loaded and the sketches were uploading just by using the FTDI. Thank you a lot for your help and information and I hope someday I'll pass this knowledge to someone who will be in the spot I was until now. Have a great time and love ya all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.