0

I'm trying to program my NodeMCU ESP8266 ESP-12E module with AT commands. However, whenever I try and flash to my ESP8266 using ESPTool, I get a 3-run stub fail error. Can anyone tell me why I get this error and how to fix it? I have my suspicions that it might be the fact that I haven't pulled any of the pins, but I've been told that GPIO0, GPIO2, GPIO15, and CH_PD are all already pulled to the proper positions by default. If that may be the reason behind this error, could someone explain to me how exactly I should pull the pins, whether it be with a circuit or through code? If it helps, I'm trying to follow along with this resource. The only thing the ESP is connected to is the computer with USB.

enter image description here enter image description here

1

Just wanted to update and let anyone who had a similar issue learn how I solved the problem. My baud rate was set to 1152000 rather than 115200. Setting it to 115200 solved my problem.

| improve this answer | |
  • 1
    It's OK to accept your own answer as the solution to the problem. – VE7JRO Aug 12 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.