1

I am working on a project that involves moving stepper motors, and the device will have to be on for upwards of hours. I am moving the bipolar NEMA17 stepper motors using a Protoneer CNC shield V3 on top of an Arduino UNO and DRV8825 stepper drivers. Though I haven't left the motors on for too long, whenever I do for longer periods, maybe 5 minutes or more, smoke starts being emitted around the 4 pins I connect my motors with. My question is that, if anyone has had a similar issue before, if they could explain why this occurs. I would also like to know if the stepper drivers are actually being protected by the heatsinks, because they can get ridiculously hot even after a few minutes and I'm worried that they wouldn't be able to last more than 15 minutes before exploding. Hopefully there's enough information here for someone to understand what's going on, but I'd glad to give more if that helps get a better idea of what's going on here. Thank you!

enter image description here

enter image description here

enter image description here

11
  • sounds like the connectors are not providing a solid electrical connection and may even be inadequate for the job ... your post does not really provide any useful info about the actual problem ... you could have asked the same thing in about 10 words ... my NEMA17 stepper motor connector is smoking. how do i correct this? – jsotola Aug 7 '20 at 19:17
  • too much heat is a problem of too much current and too much resistance; reduce both. – dandavis Aug 7 '20 at 19:17
  • How would I reduce the resistance? Just lower the current? Are you sure that the problem isn't that there's not enough resistance? – stackbear Aug 7 '20 at 19:49
  • 1
    Smoking is definitely a bad sign and not OK to run under these conditions. Take a photo of your setup. Maybe your wires are too small? Maybe your code is wrong, or your wiring is wrong and you are periodically shorting the motors, causing really high currents. – Gabriel Staples Aug 7 '20 at 20:17
  • 1
    Because none of the comments resolve your question, so aren't really answers... With regard to the OP, smoke is never a good sign... The pins can probably take more than 3A since they are just solid pins, it's the connector/quality of the connection that can't. I suspect the black plastic shrouds are a bit melted if that's whats been getting hot! Plus, the drivers (if they are the A4988 ones) are only 2A rated, so if they are being pushed harder, overcurrent and thermal protection will be hard at work. – Peter Feerick Aug 8 '20 at 4:47
3

Those NEMAs are big ones - i suspect too big for the little A4988 chips - which can only provide 2A when actively cooled and generally only for short periods. I wouldn't try to push more than 1.7ish Amps for any length of time.

You will also need to set the vREF correctly for the motors you are using - if this is not set you will either provide too little current or too much current.

Look up the specifications for the NEMAs you have - and upgrade the Stepper controller to something more like a TB6600 that can handle greater current.

Also when the Steppers are not being used - disable (if you dont need them to hold) this will turn off the drivers and let them cool between runs/moves.

2
  • How can I disable a stepper motor? – stackbear Aug 11 '20 at 20:41
  • 1
    On that particular CNC shield pin 8 is the enable pin - LOW=enabled, HIGH=disabled. – Ozoid Aug 12 '20 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.