I´m learning how to use the Arduino MKR1010. When I wrote a program for controlling LEDs and to read a BMP280 sensor with a web aplication, and I uploaded the program to the board, suddenly the computer did not recognice the board.

The power LED of the board works, but I can't access the board with my computer, and I can't see in the COM ports list, and neither as a "unrecognised device" to reinstall the drivers.

I have tried with a few others USB cables and with another computer, but I still have the same problem. I have also tried to press the reset button reset and I still have the same result. What can I do to make my board work?

1 Answer 1


The MKR board connects to computer over native USB support of the MCU. The handling of the USB is done by Arduino core functions linked at build to your sketch.

A consequence of using the native USB port is, if your sketch has a problem, it influences the USB communication. In this case you can activate the bootloader to handle the USB port and the upload. It is done by double clicking the reset button on board.

This applies to other SAMD boards (Zero, M0) and to AVR boards with native USB port (Leonardo, Micro) too.

  • I followed these steps, I connected the board to the computer, the power led is on and the chrd led is on for a few seconds, I press the board button reset two times and the board doesn't do anything. It's possible that the board it's broken?
    – mourazo
    Jul 3, 2020 at 11:30
  • @mourazo, the onboard LED should start blinking with slow fade.
    – Juraj
    Jul 6, 2020 at 12:40
  • It start blinking for a few seconds at the start, later it´s off and i can´t do anything with the board
    – mourazo
    Jul 7, 2020 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.