0

I was doing some tests with an ATtiny85 Digispark module using Arduino IDE on my Windows PC. I was testing some stuff with the DigiKeyboard library from Digistump.

Everything was going fine until suddenly the Digispark stopped working and wasn't able to upload code through the module anymore. Now when I plug it in my PC, the only thing that the module does is turn on the green led; besides, Windows doesn’t recognize the module when I plug it in anymore and doesn’t even appear in Device Manager as an unknown device or something.

I reinstalled the drivers but nothing changed. I also tried to reinstall Micronucleous into the ATtiny85 using Zadig, but wasn’t able to do it because Windows doesn’t recognize the module when I plug it in, so Zadig won't see it either.

Since I’m not very familiar with electronics, I’m not sure if there is any way to fix this or if it’s due to some physical damage, so any help or direction with how to deal with this would be really appreciated.

See image

  • are you certain that windows is not recognizing anything at all? – jsotola Jul 2 '20 at 7:11
  • Yes. I double checked Device Manager and I couldn't see it there; besides, Windows doesn't play this sound that you hear when a USB device gets connected. – Vile Jul 2 '20 at 8:49
  • afaik digispark doesn't have USB chip and the Atiny doesn't have native USB. you must program it over ISP. and again afaik, software USB bootloader can be used. a new Digispark should have it. – Juraj Jul 2 '20 at 9:47
  • @Juraj the digispark uses VUSB to implement USB in software. Programming over ISP isn't possible, as far as I know, since Digispark disables the reset pin (to use it as a GPIO). – Gerben Jul 2 '20 at 15:23
  • @Juraj I'm not sure of what you mean, from what I know, the Digispark was made to be able to program the attiny85 via USB. I was able to program this exact Digispark in the past, but in some moment something went wrong and wasn't able to do it anymore – Vile Jul 2 '20 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.