so I've got myself a Arduino Pro Micro ATmega32U4 5V 16MHz and my PC (Win10 64bit) won't recognize it. So, after I firstly plugged it in, it was detected as a Leonardo, rather than a Pro Micro, afterwards I installed hte drivers as noted by Sparkfun, and added the board to the IDE. Afterwards, my Arduino got detected as an unknown device where I can't use it anymore. I tried installing the drivers as given by sparkfun over the "unknown device" and no luck by trying, I always get an error saying that Windows has already the best drivers for it already installed.

And later, I uninstalled the "uknown device" in hope that it will re-install itself upon pluggin it back it, and it actually disappeard totally and got repalced by "Unknown USB Device (Device Descriptor Request Failed)" under USB controllers in the Device manager.

And I'm stuck here. In the IDE, the Pro Micro is detected as being on "COM1" no matter what COM port it really is, or is it even plugged it at all. Uploading a code results in the bar being filled up and "Uploading..." message, while maybe after a few minutes a very long error pops up without anything specific since you can plug out the board and get the same error.

I also tried a different PC with Windows 7 64bit on it, and instead of getting recognized as a Leonardo, this time it came straight to becoming a "Unknown device". I tried installing drivers multiple times with no luck, also again tried manually overiding the drivers in the Device manager and it always says that the best drivers are already installed.

I'm really stuck here. Pics of the board: https://postimg.cc/gallery/rwCDRfv

  • What happens if you press RESET (bridge between RST and GND briefly) twice?
    – Majenko
    Jun 25, 2020 at 19:52
  • Device Descriptor Request Failed has nothing to do with drivers. the PC can't read the PID/VID to install appropriate drivers. it may have many causes from bad cable or a broken solder on the usb socket, to the firmware itself which doesn't provide the needed information for PC. Jun 25, 2020 at 20:17
  • @Majenko nothing special. The Arduino disconects briefly, and reconnects with the same error. Also, the two leds around the crystal oscilator briefly blink, but with very very very low brigthness compares to the main led which glows all the time, even when you reset the Arduino Jun 25, 2020 at 20:25
  • @TirdadSadriNejad I heard something about flashing a new bootloader if it's a firmware problem? Could that be it. I'll also check (try to atleast) if the usb socket is badly soldered. Jun 25, 2020 at 20:26
  • 1
    If it detects ok for a few seconds when you reset then it's good. It's just the sketch that is loaded onto it that is bad. Did you install something to it and then it stopped working? Also, don't install any drivers: you don't need them. The fact that it "says" Leonardo is meaningless.
    – Majenko
    Jun 26, 2020 at 9:55

2 Answers 2


It was wrong of you to try and install the driver as this board SHOULD be recognized as Leonardo. I would try to reinstall the Arduino IDE, it will also reinstall the drivers (hopefully)

  • 1
    I made it. I shorted the RST and GND pins in the right moment while uploading the code, and it just uploaded. Now it works perfectly, without the need of reseting it. Jun 26, 2020 at 15:41

I got similar problem, I was trying to burn some HEX files and somehow, my windows wasn't able to recognize my atmega32u4 anymore, not even in Device Manager. I found that the bootloader was "bricked", and to fix it, you need to burn a valid HEX file, like the simplest led blink code. I've done that by the prompt command, using avrdude. So you reset twice, and you have 8 seconds to upload the hex file. It's faster doing that with prompt command than arduino software. After I uploaded the LED blink code successfully, the windows naturally recognized my atmega32u4 instantly, I could identify it in Device Manager as PCOM 4 since then. So you need to revive your bricked atmega's bootloader. I guess there's nothing to do with the drivers in this case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.