1

I have some problems on MacBook Pro running with Catalina. I bought new nodemcu LoLin board. Its clone. It has ch340 adapter to communicate. And writing on bottom side wemos.cc and use ch340g driver.

I succesfully installed drivers and I can see my lolin boards on port list

I upload a code that doing only print hello to serial port. I tried with 9600 and 115200 baud rates. My serial monitor show garbage data. I am using platform io with VSCode to upload code and upload time is too much.When I am uploading code I got this warning :

"Detected crystal freq 156.04MHz is quite different to normalized freq 40MHz. Unsupported crystal in use?"

I am using cheap thundeIrbolt usb converter too. But I connect with this converter to Windows pc, everything looks fine. I can see hello world on serial monitor. But on my Mac, I can see garbage only. I tried some serial monitors, Arduino IDE and platform io ide but still same.

Are there any solution about this problem?

EDIT :

I fixed issue last night. Catalina has ch340 drivers already and I setup oem driver from GitHub. Apples driver and oem drivers conflicting. If you use Mojave and higher os, you dont need any driver for ch340. So if you installed ch340 oem driver you should delete it.

I am adding the post: Platformio post

  • Can you post a photo of the board? You may have bought an ESP32 board about not an ESP8266. Also try baud rate 74400 - if it is an ESP8266 the boot loader will print messages at 74400. – romkey Jun 13 at 20:19
  • I can read on chip esp12e. Its not esp32. And chip vendor is DOITING. On windows i can use 115200 or 9600 but on mac it send to serial garbage data. – Dogan Cignakli Jun 13 at 20:23
  • And i used 74400 still garbage. – Dogan Cignakli Jun 13 at 22:07
  • 1
    You should post the solution you found as a self-answer, and accept the answer... – hcheung Jun 14 at 8:47
1

I fixed issue last night. Catalina has ch340 drivers already and I setup oem driver from GitHub. Apples driver and oem drivers conflicting. If you use Mojave and higher os, you dont need any driver for ch340. So if you installed ch340 oem driver you should delete it. I am adding the post: Platformio post

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.