0

I recently bought an Arduino starter kit off of Amazon (Elegoo super starter kit). I have been using it with my Mac with no issues up until now. All of a sudden it does not recognize the port, and I am unable to upload to my Arduino. This is very frustrating considering it had zero issues before. I have tried installing the driver Elegoo recommends, but it is outdated. I tried the most updated driver from the same website here, but that did nothing. The website claims the latest driver for Mac is 10.9 and up (I have 10.15.2) but it didn't work. If there is anyone that has had this issue recently or knows how I can fix it, that would be great.

  • Welcome to the wonderful world of Catalina. You're lucky it's worked as long as this... – Majenko May 9 at 20:50
  • Do you have either another Arduino or another computer you can try, to narrow down where the problem is? – Joseph Sible-Reinstate Monica May 9 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.