0

update: I uninstalled the portable package of Arduino IDE, completely, and installed the IDE using sudo apt install arduino. yes, I verified that my Nano was plugged in, the status on the bottom right says Arduino Nano w/ ATmega328 on COM1, but sadly the IDE won't explain to me why the Tools > Serial Port section is still unavailable.

Also, the online version doesn't recognize the board even though it's plugged in and configured in the settings to look for a "Nano". I also used a reliable USB Hub I use for my drawing tablet, because that was one of the remedies to troubleshoot the lack of connection, and because the Hub seems to do a lot of good things around here.

end of update

I received an Arduino Nano as a gift a couple months ago and had to place it on a shelf as a mere dust collector, because it was not as easy as I thought it would be to get it working. I plugged the Nano into my computer with a cable, and attempted to load an example "blink" program and it gives errors saying "no device connected" in the errors.

It does light up and flash, so I know it is receiving power, so how do I specify where the Nano is? I am familiar with the /dev category and how to use code in Linux, but I don't know how to communicate with the Arduino, as in, know which block device the Nano is in /dev

now that Thomas has brought to my attention the "port" setting in the drop down menus, I just realized that the port is greyed out. that could be a good detail in troubleshooting this issue.

  • Hey I just thought of an interesting Idea: what if I can use something like moserial to see a raw output from the Arduino? maybe then, I can see if it is at least talking to the laptop – Jaz Apr 27 at 1:05
1

In the Arduino IDE, the mcu will show up in Tools > Port. Your Arduino Nano will probably be visible at /dev/ttyUSB0 or /dev/ttyUSB1 following whatever is already plugged on USB. Make sure to select it.

Select Nano in Tools > Board.

Last step is Verify/Compile your code (^R), then Upload (^U).

This link sounds to be a good read to start.

| improve this answer | |
  • +1 that is a legitimate answer... and that also brings up the kicker. I forgot about the exact errors and issues I was having, because this was months ago, but it's all flooding back to me. the board is next to me now. the green light is steady, and the port drop-down is greyed out/ not clickable. what do I do? – Jaz Apr 25 at 2:22
1

I have to sadly conclude that this issue posted was for nothing. the board I was using most likely has an underlying defect (of all odds, the 45 boards my teacher was using, he gives me 1 defect board? believable.) rendering the board inoperable. I plugged the board into an entirely different laptop, downloaded and installed a full IDE for it, ran it normally, ran it in Administrator, downloaded and installed the plugin, ran the Online IDE to test that... same exact issues: greyed out serial port settings, and no device detected upon plugging in.

again, I apologize for this being a waste of time. I wished this was not the case and that I could make some pretty cool stuff during this quarantine mess.

I salute to all you programmers out there.... and wish you all good luck in your own endeavors in Arduino.

| improve this answer | |
0

If you have managed your Linux security well, a normal user may not have access to the port where Arduino is plugged into. If so, try from terminal with "sudo arduino". (At least works for me)

| improve this answer | |
  • in my conclusion, i stated I ran it both normally, and in super user mode (sudo arduino), but gave no results. – Jaz May 4 at 15:41
  • I hate to be that person who kicks down every answer and return it with another issue. i am not doing this for attention. I legitimately don't know what is wrong. – Jaz May 4 at 15:42
  • actually the more i think of it, i think the cable was not made for data transfer. it was a cable i found in a pile of wires so it may just be a charge cable for something else. I will try to find one guarenteed for data transfer and see if it gives better results – Jaz May 4 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.