I bought Arduino Mega board (CH341 usb) and I am able to connect to /dev/ttyUSB0 (upload to device) only by using sudo.

OS: Ubuntu 18.04

What I've tried:

  1. I have downloaded Arduino IDE and added my user to dialout group. Logged out and logged in. Still nothing.

  2. Installed Arduino by using apt

  3. Installed Arduino by using snap

For all three cases it worked only by running as root (sudo actually). I saw couple of answers for Ubuntu 14.04 but none of answers didn't help.

I guess some other device access permissions are missing but I still didn't find any solution.

1 Answer 1


After some struggle I figured out that I need to add my user to "tty" group as well.

There's another approach that involves udev rules modification for certain vendor:device and update of device's ownership but this seems more sane approach.

To recap:

  1. Add your standard user to the group "dialout'

    sudo usermod -a -G dialout your-username

  2. Add your standard user to the group "tty"

    sudo usermod -a -G tty your-username

  3. Logout/Login

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.