2

Nano 33 IOT is not detecting by windows . When i plug the usb cable only green light on the board. Board is installed from the board manager. the cable is usb DATA cable and not charging cable. I tried the double press on the reset button but nothing happen. The L light is Off and the green light isnt flashing. I plugged the board into another usb port, the same issue. I tried the board on my friend computer also but no luck. I dont have ATmel ICE or any other debugger like j-link. https://www.youtube.com/watch?v=C0tXa0uxv5c

I hope someone can explain what is the issue, is it hardware or software.

7
  • much clearer ... the first sentence describes the problem, the rest of the post is more or less irrelevant because it depends on proper windows detection ... may be a missing windows driver or may be hardware .... try plugging into a linux machine and looking at the kernel messages (dmesg) .... you can use a linux liveCD like Knoppix or Linux Mint to boot your PC – jsotola Mar 4 '20 at 0:30
  • Windows 10, 64bit. The second board ( Nano 33 ble sense) working on the same usb port. after I spent time on google I found that the problem related to missing bootloader for some reason. Many faced the same issue but few of them were successful to recover the board by double press on the reset button. – Hussam Mj Mar 4 '20 at 0:41
  • Not an answer to your problem, but just some information you might want to know. Nano 33 BLE Sense is a very different board from Nano 33 IoT, even their name suggesting they belong to the same family, but they use different MCUs. Nano 33 IoT is based on Microchip's SAMD21 32-bit ARM Cortex-M0 MCU. But Nano 33 BLE is actually use the MCU within the uBlox module which is a Nordic ARM chip. Both MCU have on-chip USB supports. – hcheung Mar 4 '20 at 1:02
  • One way to solve the Nano 33 IoT reset problem is to replace the 100k resistor connected to the reset pin with a 10k resistor. – hcheung Mar 4 '20 at 1:03
  • I mentioned the Nano 33 ble sense because i bought them from the same store and not to forget. I got Seeed wio lite w600 wich has the same MCU SAMD21 . Both broads with different mcu working fine and to eliminate the issue between the three boards. I had to mention the names. – Hussam Mj Mar 4 '20 at 11:04
2

If you upload to a SAMD board like the MKR boards or the Nano 33 IoT with Nano 33 BLE selected in Tools menu of Arduino IDE, the upload is executed and deletes the bootloader of the SAMD MCU.

The problem is that bossac uploader doesn't check the chip, because it was developed only for the SAMD chips, but Arduino created a bootloader for the Nano 33 BLE nRF52 MCU to use the SAMD bossac uploader.

The SAMD boards use the native USB support of the MCU, so without a bootloader or good sketch running the USB doesn't work.

You have to restore the bootloader on Nano 33 IoT. It is done over the SWD pads on the bottom side of the board. You can use a SWD programmer or other Arduino board with the Adafruit DAP library.

You can use your Nano 33 BLE or some other board and a SD card with Adafruit DAP library as programmer.

I had this problem with MKR Zero and I used a LPC-Link2 programmer to burn the bootloader. Once before I lost the bootloader for other reason and back then I didn't have the programmer so I used the Adafruit DAP library with an Arduino M0.

enter image description here

enter image description here

5
  • HI Juraj. My problem is that the board is not detected by windows and only green light when i plug the usb cable. and second , I dont have ATMEL ICE or any deubgger like j-link. – Hussam Mj Mar 4 '20 at 11:09
  • @HussamMj, yes, without the bootloader the board doesn't create an USB port. you can use the Nano 33 BLE or the other SAMD board and a SD card with Adafruit DAP library as programmer – Juraj Mar 4 '20 at 11:49
  • I have Seeed Wio Lite W600 which is fully Arduino Zero Compatible and I am wondering what the possibility to use this board to burn the bootloader on the Nano 33 IOT. – Hussam Mj Mar 4 '20 at 13:08
  • @HussamMj, yes, you can use it with the AdafruitDAP library, but you will need a SD card too – Juraj Mar 4 '20 at 14:25
  • I am going for the STM32 black pill. – Hussam Mj Mar 5 '20 at 2:11
2

After I waited to get my order on ebay. I managed to restore the bricked board. The issue was related to bootloader fail. either the producer shipped it without a bootloader or some kind of static discharge caused to erase or stop the booloader from working and that why windowws didnt detect the board. I used a converted cortex m3 to swd programmer debugger and one line cmd command.

Thank for all who contributed solutions. If anyone experience the same hardware failure, it is due to missing or corrupted bootloader.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.