0

I recently bought a Roshamglo from SparkFun. This uses a Virtual USB connection to the ATTiny84. I cannot find the device once it's connect.

I installed the board via https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json

I installed the Micronucleus utility via make CONFIG=t84_default, which required Libusb Dev to be installed. This appears to be running properly:

root@******:/# micronucleus --help
usage: micronucleus [--help] [--run] [--dump-progress] [--fast-mode] [--type intel-hex|raw] [--timeout integer] [--no-ansi] (--erase-only | filename)

  --type [intel-hex, raw]: Set upload file type to either intel hex or raw
                           bytes (intel hex is default)
          --dump-progress: Output progress data in computer-friendly form
                           for driving GUIs
             --erase-only: Erase the device without programming. Fills the
                           program memory with 0xFFFF. Any files are ignored.
              --fast-mode: Speed up the timing of micronucleus. Do not use if
                           you encounter USB errors. 
                    --run: Ask bootloader to run the program when finished
                           uploading provided program
                --no-ansi: Don't use ANSI in terminal output
      --timeout [integer]: Timeout after waiting specified number of seconds
                 filename: Path to intel hex or raw data file to upload,
                           or "-" to read from stdin

Commandline tool version: 2.04

When I run lsusb I see the device:

Bus 001 Device 027: ID 1b4f:0014  

I also see it loading in dmesg:

[281639.794034] usb 1-1.3: new low-speed USB device number 27 using ehci-pci
[281639.904516] usb 1-1.3: New USB device found, idVendor=1b4f, idProduct=0014, bcdDevice= 2.03
[281639.904520] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[281782.469496] usb 1-1.3: USB disconnect, device number 27
[281786.296522] usb 1-1.4: new low-speed USB device number 28 using ehci-pci
[281786.406993] usb 1-1.4: New USB device found, idVendor=1b4f, idProduct=0014, bcdDevice= 2.03
[281786.406996] usb 1-1.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0

I do not see the Board in Arduino nor does it show connect when I run the cmd:

Roshamglo-master/Bootloader/micronucleus/firmware# micronucleus --run t84_default.hex 

I get the standard "Plug in your device...", which I do, but it never shows connected.

System Info

root@******:/# uname -a
Linux OptiPlex790 5.0.0-38-generic #41-Ubuntu SMP Tue Dec 3 00:27:35 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
root@******:/# arduino --version
Loading configuration...
Initializing packages...
Preparing boards...
Arduino: 1.8.12

I don't see it appearing as a Port or Device. Trying to talk to it with avrdude manually so far has not helped.

Update

This may be a udev issue. I see the device come in but then it does not seem add or bind.

root@******:/etc/udev/rules.d# udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[292706.365174] add      /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4 (usb)
KERNEL[292706.365454] add      /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0 (usb)
KERNEL[292706.365513] bind     /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4 (usb)
UDEV  [292706.397269] add      /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4 (usb)
UDEV  [292706.399662] add      /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0 (usb)
UDEV  [292706.404374] bind     /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4 (usb)
KERNEL[292706.980898] add      /devices/parport0/ppdev0.0 (parport)
KERNEL[292706.980928] bind     /devices/parport0/ppdev0.0 (parport)
KERNEL[292706.980938] unbind   /devices/parport0/ppdev0.0 (parport)
KERNEL[292706.980954] remove   /devices/parport0/ppdev0.0 (parport)
UDEV  [292706.981510] add      /devices/parport0/ppdev0.0 (parport)
UDEV  [292706.981899] bind     /devices/parport0/ppdev0.0 (parport)
UDEV  [292706.982310] unbind   /devices/parport0/ppdev0.0 (parport)
UDEV  [292706.982660] remove   /devices/parport0/ppdev0.0 (parport)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.