1

Ok. So I'm close to tearing me hair out on this one.

I have a batch of cheap Arduino Nano clones, that just straight up won't work. (I HAVE gotten one of them to work, but I suspect that was by pure coincidence)

Anyway, I feel like I've tried everything to make them work. I am consistently getting

Device signature = 0xffffff

errors from avrdude, which I believe is a hardware problem. Up til now I have tried:

  • Installed CH340 drivers, no difference
  • Tried to burn bootloader using Uno as an ISP (with 10uF cap between reset and ground!)
  • Tried the "(Old Bootloader)" option in the IDE

All I have left is to desolder the entire board and troubleshoot each single component, but... no, I want to keep my sanity intact, thaaank you!

Any ideas on how I should move forward here?

6
0

Hit reset randomly in the first few seconds of uploading/burning.

1
  • 1
    Tried, no change. Thank you though!
    – Pigface333
    Feb 26 '20 at 8:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.