0

Tried to install Arduino IDE on Juno, install script gave warnings about icons not being installed on desktop (which is fine since no desktop folder for eOS) but then when try to launch the IDE icon from Applications it doesn't go. I'm guessing it's a java app? I don't want to run java on eOS unless it's already there. Any insight to running this IDE on Juno would be welcome.

  • 1
    Yes, the Arduino IDE is java, so you need java to run it. You could try to use arduino-cli (commandline tool to compile and upload code to Arduinos). It seems to be written in go – chrisl Feb 21 at 19:30
  • 1
    "it doesn't go" is not a good problem description. Have you tried running the Arduino IDE from a terminal and watch, if errors are displayed there? If yes, these errors belong into the question. – chrisl Feb 21 at 19:31
  • I'd be fine w just coding and compiling. Am obv new so didn't know IDE had a cli (sounds counterintuitive). Doesn't go means I click the icon and app doesn't launch. Am setting this all up for the first time so be kind. For now am able to download hex files to the hardware, so am going to backstep and try hand compiling some code via gcc. Not a fan of java so prob isn't on my system by default. No other IDE option? – iGuest Feb 21 at 19:48
  • 1
    The CLI is not part of the IDE. It's an extra program. For the case, that you want to stay in the Arduino Framework without much configuration. You can use any C++ IDE to write the sketches as ino files. Then you can execute the compilation and uploading over the CLI. Another option would be Atmel Studio, though I think you need to configure it to use the Arduino framework (google might help you there. Haven't done that myself). – chrisl Feb 21 at 20:04
  • version for what platform did you download? Linux 64-bit? To what folder did you unpack the installation? The IDE has Java bundled. The install.sh only creates a desktop icon, nothing else. – Juraj Feb 21 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.