0

I suppose this might be more an environment question regarding Platform.io and VSCode, as my code works great in the Arduino IDE, however the lack of syntax highlighting is driving me mad.

I've setup a Platform.io project in VSCode, copied my code across and setup my board (Wemos D1 Mini)

My platformio.ini file looks like:

[env:wemos_d1_mini32]
platform = espressif32
board = wemos_d1_mini32
framework = arduino

There are a couple of headers that are highlighted as having errors:

#include "FirebaseESP8266.h"
#include <ESP8266WiFi.h>

I've installed FirebaseESP8266 to my project from the PlatformIO libraries, however it still says:

include errors detected. Please update your includePath. Squiggles are disabled for this translation unit (C:\Users\Greg\Documents\PlatformIO\Projects\Lovebox\src\main.cpp).C/C++(1696)

If I try to build it errors with src\main.cpp:1:22: fatal error: Schedule.h: No such file or directory

As for the ESP8266WiFi library, it simply says cannot open source file "ESP8266WiFi.h"

Anyone know where I'm going wrong?

1

Did you install the libraries you need / use?

You could do it either via the platformio screen or add the names directly to the platformio.ini

lib_deps =
    Firebase ESP8266 Client@>=2.7.8

And additionally ESP8266WiFi.h is an ESP8266 library
for the ESP32 you should use the lib #include <WiFi.h>

EDIT: To update the project libraries, select 'Update Project Libraries' from the project tasks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.