0

Hi my Arduino Uno stacked with a motor driver shield was working perfectly however I am using the same board for a while now and suddenly my board stopped working. When I upload a code no matter what code is the LED's on the board respond however the code is not executed it does nothing , the board doesn t even beep anymore. Is there a way to clean the memory or something? Please help.

4

To check if you really cannot upload anymore (assuming it's not a software error), try the following sketch

https://www.arduino.cc/en/tutorial/blink

This will blink the BUILTIN led.

There is very low chance to wore out your memory, you can write lots of times to it (like 10,000 times guaranteed, in practice mostly more).

But there can be another hardware problem, but first check if this simple sketch works.

Also (based on jsotola's comment), remove shields/wires.

Especially wires/shields using RX/TX since these pins are (somehow) used for loading a sketch.

  • @jsotola good point, I will edit my answer – Michel Keijzers Feb 7 '20 at 9:06
  • 1
    Yes thank all codes that i tried work with just the Arduino Uno however when I stack the motor driver shield l239D i cant upload any code it says that an error has ocurred while uploading the sketch. – Noslen Feb 7 '20 at 12:55
  • That's probably because the shield uses some GPIO pins, especially RX/TX... So that means every time you want to upload a new sketch you have to remove the shield. – Michel Keijzers Feb 7 '20 at 12:58
  • 1
    Hmm thank you are you saiyng that if i upload a code to Control motors just to the Arduino board without the driver shield atached and the i connect the driver shield it Will work? – Noslen Feb 7 '20 at 13:01
  • 1
    Michel keijzers thank you so much man really it worked just fine!!! Thank you realy you do made Diference. – Noslen Feb 7 '20 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.