0

Sorry if this is something simple, but im scratching my head over this for a while and there are a few things that have me super confused.

I have two WS2811 strips lighting up my outdoor stairs Both are powered from a central point, using Cat5 Cabling to get power and data from the controller to the start of each strip

Iv been running it from a Nano perfectly fine for a while, but wanted to add networking so upgraded to a NodeMCU

I first started on just one strip to confirm it worked as expected, and after setting about 50 of the 80 leds it started to glitch, so I added a 3.3 to 5v converter and the issues went away.

I then went to work on the second strip, and was getting nothing from it, no commands sent to the strip were working, the first strip kept working fine however.

I swapped around the pin outputs and converters in case it was a faulty part or bad pin, but no matter the combination, it worked 100% when using the first strip, and never worked on the second.

So i put my Nano back in, running the same color swap test code I had, and both strips worked fine, put the Node back in and only the one strip worked.

I then got a small test strip and connected it directly to the output of the converters and when it was on the one for the first strip, it worked fine (With both the test and first strip displaying the same test) But when I put it on the output for the second strip, the test strip would turn off as if it was getting a "Set all to 0" command.

I disconnected the cat5 that connected the converter to the second strip, and the test strip started working. So I thought there must be a short or something on the cat5 So I disconnected the LED strip from the other end and did a continuity test, and none of the leads were shorting (Pos, Neg and Data)

So I put the cable back onto the converter, with nothing on the other end, and the test strip stopped working again, I dont know if the length of the cat5 is causing a capacitance issue or something, even though its only connected on one end (Converter end) And it works fine with the nano, only when its the Node and only with the second strip do I have problems

Hopefully my description makes sense, and someone has some idea of whats going on

Link to diagram of my setup https://imgur.com/a/pTefyR5 And happy to try make a short clip if a visual guide would help explain my problem

Thanks in advance

  • Can the library you use drive two strips at once on the ESP8266? – Majenko Jan 12 at 14:55
  • Yes, works fine when I have it on my testbench, it only breaks when I add the CAT5 cabling, even without the second strip connected at the other end – Thomas PomTom Steel Jan 12 at 17:13
  • cat5 is likely the problem. you don't want a long run between the MCU and the LEDs. are your LED's really 12v WS2811 ? where did you get them? – dandavis Jan 13 at 20:04
  • for reference here is alink to a video showing the problem youtube.com/watch?v=NnYTCVuATZM – Thomas PomTom Steel Jan 13 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.