So I think the title says it all. I recently purchased an ESP32 CAM in India for a pretty cheap price.

It looks like an AI Thinker but doesn’t have the tag on the chip itself. Nonetheless, to get it setup before my use case I decided to test the camera. I loaded up the CameraWebServer example and set my camera type to AI thinker.

The code uploads successfully and runs successfully. I can open up the IP address and it shows the page. However whenever I try to get a still or start a stream, it gives this error:

[E][camera.c:1344] esp_camera_fb_get(): Failed to get the frame on time!
Camera capture failed

It’s pretty annoying and this happens in both 5V power and 3V power. The camera does physically get a bit hot after loading the website. Oh yeah, I have an OV 2460 Camera attached to the ESP.

Any advice is appreciated. Thanks!

  • I just bought 2 esp32-cam-mb, one is working fine, the other gave error 1483, I swaped the cam with a spare one I had, and it is working. Titi
    – Titi
    Commented Apr 26, 2022 at 18:15
  • esp_camera_fb_return(fb); add this to your code
    – R242
    Commented Oct 14, 2022 at 19:18

5 Answers 5


Solution for if this occurs on a known working ESP-32-cam with PSRAM (i.e. example sketch with face recognition works ok).
If you're using anything other than PIX_FORMAT_JPEG, try reducing xclk_freq_hz.
In my case, it suddenly worked fine with PIX_FORMAT_RGB888, FRAMESIZE_VGA and xclk_freq_hz = 5000000 (4x lower).

( @Vraj P, this might not apply directly to what you found your problem was, but this post gets seen by many searching for this problem. Thanks!).

  • For me, reducing the XCLK frequency from 20 MHz to 10 MHz worked.
    – h2stein
    Commented Feb 17, 2023 at 11:41
  • Over here, it was trying to compile with esp-idf idf.py with VSCode. Instead, compile esp32cam code with arduino-ide. Or use the arduino-cli compiler with VSCode for intellisense and a better editing experience. For some reason, the code compiled with idf is runnable but creates this error of not being able to get the frame on time, no matter what settings are used. xclk_freq_hz et. al.
    – hellork
    Commented Mar 11, 2023 at 6:23

I had tried and tried to get the camera working. However, I decided to concede to the part of me that thought it was a hardware error. I purchased a new OV2640 module and instantly it worked.

I think I learned my lesson in purchasing cheap components. I inspected the old one further. Turns out there was a faulty ribbon cable. Anyways, I hope you aren’t in this situation. Seems like the only solution is to purchase new hardware, and the current issue is faulty hardware.

  • THIS is not a solution.
    – pikkuez
    Commented Mar 21, 2020 at 8:35
  • I have one ESP32 CAM unit out of a dozen that randomly fails to get the picture. I tried all kinds of settings, and swapped the OV2640 a couple of times. Eventually I figured the placement outside of the house was the issue. The wifi is solid no matter where the device is placed, but on one spot the camera fails every time. It has to be some kind of electromagnetic interference. If I move the camera a few feet left or right, it never fails. The shielding within the ESP32 cam board has to be defective as it just affects this one unit. All my other devices work fine wherever they are placed. Commented May 15 at 17:24

This stung me too. I found increasing the frame buffer count helped.

camera_config_t config;
config.fb_count = 10;  // Or some other number

One possible cause is given here (scroll down to find this specific issue) https://randomnerdtutorials.com/esp32-cam-troubleshooting-guide/

There appear to be two sets of ESP-32-CAMs, one with and one without the PSRAM.

  • 1
    This is something that I did come across, but like I said, using a new camera module worked instantly. This probably meant that in my case it was a simple hardware error.
    – Vraj P
    Commented Jun 30, 2020 at 15:13

Look I've just had that problem for a month and if you're using esp32- ov2640 look the camera reference because the one I've had was TY 0V2640-V2.0 and what I've saw it's like a cheap copy of the normal camera, so be careful. I had to buy a new one because everything looked like a broken image, although all the config worked fine. Even changing the PIX_FORMAT and xclk_freq_hz didn't work. The camera was the problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.