0

I am using a arduino uno and neo 6m gps module. The problem I am facing is quite weird. When I connected the setup the data from neo6M was seen in serial monitor, I even printed it on a Oled display. It was a close room at night. I used tiny gps plus plus library to parse the data. I got both latitude longitude. After disconnected the circuit i tried again and that is when nothing came out in serial monitor. The same sketch did not work for a day. But again at afternoon at some point i got the data properly. Sometimes the red led is blinking but nothing happens. While I change the rx and tx pins in software serial it got data but then again same problem and changing pins don't work. I have tested it in front of my window so there must be a good signal. Can someone tell me what is wrong with the system? I have so far waited long enough like 10 mins to get the data but nothing. I have to present the project by tomorrow in office. This is the code : https://pastebin.com/TMRYXFNw

  • I am using this tutorial lastminuteengineers.com/neo6m-gps-arduino-tutorial – sdebarun Dec 1 '19 at 19:09
  • Unless you can format your code properly (select it, then press the {} button in the editor) no one is going to look twice at your question. – Majenko Dec 1 '19 at 22:22
  • Sorry for that. But in my phone i did not have a formatting option. – sdebarun Dec 2 '19 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.