0

I use etherCard Library with ENC28J60-EDC8J60 ethernet module

When plugging the "backSoon" example into an arduino UNO, everything works fine, but when i plug it into a nano, as seen in some tutorial videos where it works, the ether.begin(sizeof Ethernet::buffer, mymac, SS) of the example never seem to return.

I changed the nano, the shield, the wires, tried a slaveselect value of 8 instead of 10, tested the SPI with a RFID reader just in case, and tried some other old libraries like EtherSia or some code with the basic "Ethernet.h" but i cant seem to get any IP given, getting 0.0.0.0 for example.

Maye it has something to do with some specificity of the nano compared to the uno, but tutorials and the very little doc dont mention anything.

  • 1
    what shield exactly? – Juraj Nov 12 at 17:41
  • my shield is a edc8j60 : aliexpress.com/item/32697483659.html – Neil Nov 13 at 10:22
  • that is a module, not a shield. how do you wire it? it should be powered be 3.3 V but the 3.3 V on Nano can't deliver the currentneeded – Juraj Nov 13 at 10:32
  • my bad, it is indeed a module, i wired it using the UNO pin connections like so : aelius.com/njh/ethercard, wich i assumed to be the same on nano due to the tutorials and lack of documentation. after your comment i triend powering it with the uno while keeping the CS/SO/SI/SCK on the nano but with no success, i don't understand why the nano 3.3V cant deliver the current needed though. – Neil Nov 13 at 15:23
  • 1
    the current draw of enc28j60 is 160 mA. the Uno 3.3 V pin has max 150mA. "the Arduino Nano 3.3v regulator is the FTDI usb to serial ic. That has a max current rating of 50mA. " electronics.stackexchange.com/questions/67092/… – Juraj Nov 13 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.