0

I programmed the 8mhz internal oscillator Bootloader to a new Arduino Nano with another Arduino nano running the ISP Sketch, wich worked fine the first time(Arduino as ISP selected as programmer). (I wanted to test it befor i want to burn this Bootloader on an Empty 328p-au uC.) But now since I received the 328p-au uC's i tried the same thing, to burn the Bootloader to the epty uC's but somehow it can't read the device signature, neither from a fresh arduino Nano or another avr(At least that is what avrdude said). I wired everything exectly like it was written in the ISP Sketch.

Here is one of the error messages i received when I was trining to Burn the standard 16mhz Bootloader:

     Programmer Type : STK500
     Description     : Atmel STK500 Version 1.x firmware
     Hardware Version: 2
     Firmware Version: 1.18
     Topcard         : Unknown
     Vtarget         : 0.0 V
     Varef           : 0.0 V
     Oscillator      : Off
     SCK period      : 0.1 us

     Fehler beim Brennen des Bootloaders.
     avrdude: AVR device initialized and ready to accept instructions

     Reading | ################################################## | 100%          0.02s

     avrdude: Device signature = 0xff0000
     avrdude: Expected signature for ATmega328P is 1E 95 0F
     Double check chip, or use -F to override this check.

     avrdude done.  Thank you.

So what am I doing wrong? (Using -F is what I tried but it didn't work, except the first time I programmed the 8Mhz Int. Oscillator Bootloader)

What stand out to me is that there was nothing happening on the MISO line. Here is a screenshot from my Logic Aalyzer software: ibb.co/hWXrpp7

And here is an Image of my setup(the right Arduino is the programmer and the left one has the empty uC soldered onto it): https://ibb.co/zXQFmwR I am relative new to Arduino, so I hope some of you can help me with that.

  • do you have "Arduino as ISP" programmer selected? – Juraj Nov 1 at 5:43
  • Yes I did... Same error message. – Lukas Kamina Nov 1 at 9:07
  • so do you use other Arduino with "Arduino as ISP" sketch or not? because then there are no other programmer options for "same error". show in Question the output with the right programmer selected – Juraj Nov 1 at 10:20
  • Yes I use the "Arduino as ISP" Sketch and have " Arduino as ISP" Programmer selected. "Same error message" I just tried to programm by using avrdude directly to implement the idea of the other guy who answered but it didn't help. – Lukas Kamina Nov 1 at 12:15
  • do you have a capacitor on programmer Arduino to prevent the reset at new USB connection? – Juraj Nov 1 at 12:43
1

It seems that you are using too high programming speed. SCK period al of 0.1 us renders 10 MHz, which is to fast if crystal is working at 8 MHz. Not sure where to change it in Arduino environment, but you should add this key to avrdude.exe run string:

avrdude.exe -B 8

This will set programming speed to 125 kHz. Also I suggest you to buy a cheap USBasp programmer from eBay or AliExpress. It is well documented and have plenty GUI programs, running on top of the avrdude. In newest Arduino IDE you can generate hex files in the sketch directory, and burn it with programmer.

  • Thanks, but I tried this and it didn't work. It was awfully slow but I was getting the same error message(this time I was using avrdudess, gui for avrdude). Well I bought such a cheap chinese USB ISP wich doesnt work, so i was trying to reprogramm the uC on this Programmer by following a tutorial. But as I said, I can't proramm using the Arduino nano anymore. – Lukas Kamina Nov 1 at 9:34
  • Oh and I monitord the SPI signals using a Logic Analyzer, so it seems like the Clock is running with 125khz, but as you may or may not see is that Nothing ever happens on the MISO line.... – Lukas Kamina Nov 1 at 9:38
  • ibb.co/hWXrpp7 – Lukas Kamina Nov 1 at 9:38
  • @LukasKamina You should edit your question to include that information. All the relevant information should be included in your question. – sempaiscuba Nov 1 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.