-3

This is another post where I am getting the dreaded verification error. Pretty much exhibiting the same thing that many other people are experiencing. So I will cut to the chase.

I haven't touched the Arduino for a couple of months. The code that I am working from was working. I use source control and pulled a previous version that I know compiled and uploaded successfully before and I get the same error.

In addition, I uploaded the blinky code on to the Arduino and it worked fine. Not sure what is going on here.

FYI, I am using to the Arduino uno and the Atmel ICE programmer.

I tried re-burning the bootloader but I get the verification error.

Edit:

I should also mention that I am not using one of the development boards but a custom board that I received from a client.

Here is the exact error:

Uploading...
avrdude: verification error, first mismatch at byte 0x1556
         0x68 != 0x90
avrdude: verification error; content mismatch
An error occurred while uploading the sketch
[Error] Exit with code=1
  • 4
    And... are you going to tell us what the error you is you are getting? And the code you are getting it in? – Majenko Oct 14 at 20:58
  • I am getting the verification error. Bytes are not aligning properly. That is issue. I would post the bytes but the bytes change when I make a change in the code. I would post the code that I am getting it in but the program is large. There is no particular section that it is happening at. – philm Oct 15 at 14:43
  • Dead chip? Badly designed board? Could be anything. We can't tell, since we don't have your suspect board. I suggest you try with a real Arduino board that uses the same chip. – Majenko Oct 15 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.