I made a smart dustbin using arduino, servo motor, & ultrasonic sensor. It worked pretty well for a few number of days. But once I don't know how but the Arduino 'ON' light started to become dim and switched off. I used a 9V HW battery. So I decided to plug in my arduino with a 7V AC charger, still no luck, the arduino did not turn on nor the ON light. Then I plugged the arduino to my PC, the ON light turned on for 2 to 4 seconds and switched off. I realized it became too when I touched the usb port. The ATMEGA chip did not become hot. Please help?

  • why do you expect the chip to become hot? – jsotola Oct 8 '19 at 18:01
  • 1
    Unplug everything (servos and sensors) and try again. – Gerben Oct 8 '19 at 18:54

If the USB chip is hot, you are out of luck.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.