-1

I'm testing SIM800L module by registering to network manually and I'm getting an error message. Here are the commands I tried.

AT+CSQ

+CSQ: 31,0

OK

AT+CBAND?

+CBAND: EGSM_MODE,ALL_BAND

OK



AT+COPS=?

+COPS: (1,"Bharat Karnataka","CellOne","40471"),(2,"Airtel","AIRTEL","40445"),(3,"Hutch-Kamataka","HUTCH","40486"),,(0-4),(0-2)

OK

AT+COPS=1,1,"40471"    

ERROR

AT+COPS=1,1,"40471" is this command right? My SIM card is CellOne and it's 4G.

Power supply -7.4 li-ion 1100mAh battery with an adjustable 5V-5A buck converter(3.8v is supplied to SIM800L)

1

For the AT+COPS command you are setting manual with long alphanumeric network name but then using the numeric network name. Try AT+COPS=1,2,"40471"

REF

//Manually select T-mobile as carrier using short format alphanumeric network name
AT+COPS=1,0,"TMO"

//Manually select T-mobile as carrier using long format alphanumeric network name
AT+COPS=1,1,"T-Mobile USA"

//Manually select T-mobile as carrier using numeric network name
AT+COPS=1,2,"310260"

AT+CSQ checks the signal strength, you can check the reply range with a question mark,

AT+CSQ=?

+CSQ: (0-31,99),(0-7,99)

OK

The first number, 31, shows you have a good signal strength locally.


AT+CBAND? shows the mobile operating band set


AT+COPS=? will search for networks, your response indicates you found a few.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.