0

Yesterday I was working on Arduino based bluetooth car. I was using adafruit motor shield v1. Arduino and shield were on same power supply(11v li-ion cell battery). Every thing was fine. I decided to add some leds to my car. I connected two leds with 5v on shield pins(leds were in series and were multi-colored so 5v was okay). It worked for sometime but later it stopped working. Green led on arduino was on while other were off. I disconnected shield and supplied arduino from dc jack, same result. Then I connected arduino with usb cable then everything was fine. Now it works because I supply arduino from usb and shield is working too either from usb supply or external supply. What could possibly go wrong?

enter image description here

  • it was 11.70 as measured with multi-meter – muhammad shahzaib Sep 21 '19 at 5:14
  • i tried but voltage on shield 9v header was okay – muhammad shahzaib Sep 21 '19 at 5:21
  • bad voltage regulator probably – jsotola Sep 21 '19 at 5:29
  • Thanks for adding the image of your Arduino Uno R3. – st2000 Sep 22 '19 at 1:35
1

It would appear that the output of the power regulator pin has been vaporized.

enter image description here

From the Arduino R3 schematic we see this part as U1 which is an NCP1117ST50T3G power regulator. Here is that data sheet for that part. From that data sheet we see the physical image of the part.

enter image description here

It appears that pin 2 has been vaporized. If we look at the schematic of the Arduino R3 we see where pin 2 supplies the regulated power to the rest of the Arduino board and likely any connected electronics. Note the red "X" indicating the vaporized pin 2.

enter image description here

The schematic and the data sheet both indicate the regulator's TAB is also an output. If true it is difficult to explain why pin 2 vaporized. Perhaps this particular version of the regulator does not use the TAB as an output. Or perhaps the Arduino R3 PCB and schematic do not agree.

Added later...

There has been a comment that U1 (the NCP1117ST50T3G power regulator) may sometimes be manufactured with out the center pin. Still, if you can power the Arduino R3 using the USB port and unable to power the Arduino R3 using power through the barrel jack, the likely suspects are U1 and D1. However, to be sure, you would have to check the voltage before D1 and after U1.

| improve this answer | |
  • I'm confused. How are you posting images of the OPs Arduino? Or are you describing a failure you have seen? Your post is unclear. – Duncan C Sep 21 '19 at 20:03
  • @DuncanC, It appears the person asking the question has posted twice. The second time with a picture. I advised him in the other post that he should have edited his original post. I was hoping he would follow through and delete his second post and move his picture to his original post. – st2000 Sep 21 '19 at 20:28
  • how can i delete question asked before – muhammad shahzaib Sep 22 '19 at 6:33
  • Your second question has been closed so the option to delete it may no longer be available (there are a number of options following your question just left of your avatar). Every stackexchange web site has slightly different rules tailored for that group. There are dozens of stackexchanges sites ranging from Arduinos to Law to Physics. – st2000 Sep 22 '19 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.