-1

I bought a Quectel BG96 a few days ago, and connected it to my Arduino. But I can't use it because I get an error message on virtually every AT-command I'm sending to the device. Sometimes I get some text ahead but it always ends with error. Do you have any idea what the issue there could be? I tried different antennas, sim-cards plugged in an extra battery but nothing works. I can't even get to the part where I connect to a mobile network because AT+COPS gives me an error even AT+CSQ just returns an error. ATZ0 and AT aswell. You need these to set it up based on this source. What should I do initially to set it up? Do have any idea what the problem could be?

I'm using the following code on my Arduino Uno:

#include <Arduino.h>
#include <SoftwareSerial.h>
SoftwareSerial mySerial(10, 11);

void setup()
{
  Serial.begin(9600);
  while (!Serial)
  {
  }
  Serial.println("Welcome to use NB-IoT Shield QG96");
  mySerial.begin(115200);
}
void loop()
{
  if (Serial.available())
  {
    mySerial.write((Serial.readString()+"\r\n").c_str());
  }
  if (mySerial.available())
  {
    Serial.write(mySerial.read());
  }
}

Some of the responese I get over the serial monitor are:

Welcome to use NB-IoT Shield QG96

ATE0

ERROR

ATI

Quectel BG96 Rev⸮sion: BG96M⸮R02A07M1G

AT+CREG?

ERROR

  • Maybe you have the wrong line ending being sent... – Majenko Aug 17 at 16:05
  • That's all the information I have, I get nothing more than an ERROR response. What else do you want to know? I told you what I've already tried and the current behaviour – Cowboy_Patrick Aug 17 at 16:06
  • I always end it with a carriage return and a newline just as the documentation tells you to do – Cowboy_Patrick Aug 17 at 16:07
  • You are communicating directly with the AT port through USB, yes? – Majenko Aug 17 at 16:33
  • which commands do work? – jsotola Aug 17 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.