0

im trying to connect to my wifi with mit Nodemcu, i recently got a new router and since then i can't connect anymore. I use simple example sketches from esp library but it will not connect. Instead i get a lot of dots in the console. I disabled firewalls of my router, mac filter is disabled(as i tried to manually add the nodemcus mac to mac filter it said "invalid macadress" ) if intry to connect to my phones hotspot, everything is fine.but i can't connect to my home wifi, ssid and Passwort are 100% correct. My hardware is fine, i ordered a second nodemcu and it has the same problems as the old one.

Can someone help me please, i've set my entire rooms ligthing on the node mcu and now im living in the dark ...

  • is the new AP 5 GHz WiFi? – Juraj Aug 8 at 15:01
  • No i have 2.4 ghz and 5 ghz but i disabled 5ghz :/ – Pepe123 Aug 8 at 15:04
  • This goes to show that one shouldn't ever rely on a single point of failure to make a home 'smart'. – stevieb Aug 8 at 20:09
  • You'll need to review the logs of your access point device to see why it is failing your requests. If it's a low-end residential device, it probably doesn't have any logs for you to review. What have you tried on the MCU side code-wise, to observe what may be happening on its side of things? – stevieb Aug 8 at 20:11
  • Turn on all the debugging you can in the IDE to see what your code is doing over the serial port – Majenko Aug 8 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.