0

I have a little and common application in which a sc-28 moisture sensor reads humidity levels and turns a servo (which drives a little faucet) if the soil needs water. Arduino nano is the brain.

All of them is tested and working fine on the proto board. Soil sensor is powered by 5v rail of arduino and everything seems fine even with the servo pulling from 5v rail too.

With all working, I try to translate that to a perfboard. The only difference in circuits are how they are powered.

While the prototype is powered via usb, the definitive one is powered through a 24v psu, leveling the voltage with a lm2596 module down to 5v.

Then this 5v feeds the nano (vin pin) and servo, while the soil sensor still pulls from 5v rail of the arduino to avoid vref problems.

And then, the sensor does not work. No led indicating power or data. This were my steps trying to debug it:

  • Triple check every connection on the board. While I am a decent programmer, my solder skills are kind of lacking. But everything looks fine, nothing shorted or loose.

  • measure voltage. On the perfboard, voltage between vcc and gnd connector pins spits 4.78v, which is supposed to be in range for the sensor to work.

  • Power the board through usb I tried this too, and is not working. Lm module and arduino lights up, code can be executed. I can't explain why the lm2596 module lights up too, and I'm thinking is part of the problem but I do not know. Voltage at soil sensor is still 4.78

And then I'm done. I dont know what could be happening and I only can make wild guesses. It's obviously a board problem, and i am aware I am doing something wrong but I can't see it.

Below, my horror soldering skills and the board. Soil sensor is the 4pin females at the bottom left and servo the 3pin males at the bottom right.

image 1

enter image description here

  • Picture doesn't work. Attach the image directly in the post. – Majenko Aug 4 '19 at 21:35
  • Are you sure, that you are feeding 5V to Vin? 5V is not enough there, since Vin is connected to the regulator, which needs 6 to 12 V. Have you tried to connect your regulated 5V directly to the Nanos 5V pin? – chrisl Aug 4 '19 at 22:00
  • you missed an intermediate step ... power the protoboard from 24V power supply ... your question is pointless until you do that – jsotola Aug 4 '19 at 22:15
  • @jsotola that is not possible. I guess I could make a point to point wiring in site, but I am unable to get 24v on the protoboard at this time. – David P. Aug 4 '19 at 23:01
  • do the opposite then ... power the prototype from USB – jsotola Aug 4 '19 at 23:09
1

The answer was, in fact, my poor experience with these boards and how they work.

As you can see in the pictures, wire and connectors are on opposite sides of the board. I was assuming that pads were connected on both sides, which is not true. Therefore, connectors were simply dead.

Soldered again at the wire side and it works like a charm. Thank you all for every suggestion, and the learning experience.

| improve this answer | |
0

Then this 5v feeds the nano (vin pin)

Can't feed 5V into Vin and get 5V out. Connect 5V to the 5V pin.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.