0

I'm a hobbyist trying to up my arduino and electronics knowledge. I can successfully control a hobby servo using an motor driver shield (https://learn.adafruit.com/adafruit-motor-shield/overview) but am running into issues when I try to control it without the shield using standard servo control circuits.

When the servo is connected to the basic, unworking circuit, it generally doesn't move and clicks occasionally, as though underpowered. It works flawlessly with the shield, when powered just through the standard 5V USB connection.

Schematic of circuit that doesn't work: enter image description here

Schematic of circuit working with shield (shield is approximation from fritzing):

enter image description here

I've tried :

  • a 470uF or 1000uF decoupling capacitor between ground and +5V. Also tried with no capacitor.
  • powering the servo and/or arduino from an external power supply. Grounds are connected correctly.
  • Different 5V power supplies. (batteries intended for phone charging, 5V from computer, 5V from wall).
  • Different Arduino Unos.
  • Different servos.

Code running on Arduino:

#include <Servo.h>

Servo servo;

void setup() {
  servo.attach(10);
}

void loop() {
  servo.write(135);
  delay(500); 
  servo.write(45);
  delay(500);
}

I'd like to understand what I'm doing wrong, how to troubleshoot, and/or what the shield is doing that the basic circuit is not.

I'm using Arduino Unos, a hobbytech YM-2765 servo (rated for 4.8-6V), or a 3001HB servo.

  • 1
    The wiring diagram you link to shows the servo on pin 9. Yet your code has the servo on pin 10. Do you actually have the servo on pin 9, or on pin 10? Please show your actual wiring, not a picture of what you think you followed. – Majenko Jul 2 at 9:36
  • Servo is on pin 10, sorry for confusion. Have updated with schematic of wiring. I note that these are still technically a picture of what I think I followed. Let me know if actual images or a circuit schematic would help. – GoodNamesTaken Jul 3 at 1:46
  • Your schematic shows you feeding 5V to Vin. Vin feeds the regulator and needs at least 7 volts. If you have regulated 5V then feed that into the 5V pin. – Delta_G Jul 3 at 2:00
  • Switched to 5V pin - same issue. Updated schematic to reflect this. – GoodNamesTaken Jul 3 at 2:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.