0

I've found lots of issues about serial ports not showing up at all, but none about what I'm experiencing.

Sometimes I can see my Arduino Mega 2560 in the ports list, and sometimes I can't. I've tried unplugging, replugging, rebooting my PC, and installing various CH34X USB drivers

Is there some way I can troubleshoot this issue to work out where things are going wrong?

EDIT: I have a Macbook Pro 2017 with Thunderbolt 3.0 ports connected to an adapter that lets me plug in USB. The Mega is a CH340G -> Wemos® Mega +WiFi R3 Module ATmega2560+ESP8266 32Mb Memory USB-TTL CH340G Compatible For Arduino Mega NodeMCU ESP8266.

EDIT #2: It looks like it's working again, all I did was switch around some of the DIP switches and change it from RX/TX0 to RX/TX3, sometimes when that stops working ill change it back to RX/TX0 and itll start working again. I suspect it has something to do with the USB-C adapter but haven't nailed it down yet.

  • 1
    maybe you have a bad usb cable – jsotola Jun 22 at 2:58
  • @jsotola would a bad USB cable only work sometimes but not other times? surely the fact that it was working for a while means the USB cable is okay? – user2620825 Jun 23 at 4:30
  • A cable could work "sometimes" if one or more of its connections were poorly soldered (for instance) and conducted or not, depending on how the cable was flexed. I'd certainly call that a bad cable. You could try flexing the cable near either cable-head, or (less likely, but who knows?) along its length, and watch your PC for detection or not. Or simpler: try another cable, especially a known good one if you can. If one works, and one works "sometimes", well .... – JRobert Jun 23 at 17:21
  • Thanks @JRobert I'll try with a couple different USB cables – user2620825 Jun 23 at 23:04
0

A colleague at work was struggling with a similar problem just two days ago.

He said he resolved it by reinstalling the USB driver. I did not pay much attention to more details (because I did not have that problem). If you can not work how to reinstall and none can advise how, I can ask him on Monday.

In the meantime here are a couple of reinstall the USB driver links:

https://www.roland.com/global/support/support_news/18091014/

https://forum.arduino.cc/index.php?topic=570440.0

https://support.serato.com/hc/en-us/articles/115001883474-macOS-High-Sierra-10-13-macOS-Mojave-10-14-and-above-driver-install-process

Hopefully one of these will help you.

Here is the link that my colleague followed:

https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver

All I can add is that this one worked for him. He has I have High Sierra (version 10.13.3) and needed to reboot after the installation.

  • thanks @GMc I've tried reinstalling drivers a couple of times now to no avail – user2620825 Jun 23 at 4:50
  • I will try to catch my colleague tomorrow and ask him for more details about what he did. – GMc Jun 23 at 12:12
  • @user2620825 I've finally caught up with my colleague and updated my answer with what he did. Hopefully this will help you with your problem, – GMc Jun 25 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.