0

How can I get my programmer board/windows computer to recognize my board again. I am using the esp32 cam and have put two boards in a state where I am unable to flash them anymore. here is the error:

serial.serialutil.SerialException: could not open port 'COM5'WindowsError(2,'The system cannot find the file specified.')Failed to execute script esptoolthe selected serial port Failed to execute script esptool

I tried reinstalling the drivers and understand that the com port is a separate chip https://gist.github.com/wybiral/2a96c1d1605af7efa11b690586c4b13e

Here is the sketch I used. I uploaded it using the dev module board setting as well as with 80mhz and 112500 speed. I uploaded with 3v and then provided 5v to the board to run the sketch. The sketch runs but prints out gibberish.

Edit:

Here is a schematic of the board https://github.com/SeeedDocument/forum_doc/raw/master/reg/ESP32_CAM_V1.6.pdf

6
  • You can't "put them in a state" where the COM port can't be found. The COM port is a completely separate chip. Check your USB cable. Reinstall the drivers.
    – Majenko
    Jun 18 '19 at 11:55
  • 1
    And check if the boards still have COM5. Sometimes the numbers change
    – chrisl
    Jun 18 '19 at 12:26
  • thanks fellas for the quick replies. I tried reinstalling the drivers for the USB device in question. holding down the reset button before doing so. However, while the com port is still there, it says the drivers are up to date. Jun 18 '19 at 12:36
  • Is there a way to reinstall the drivers other than uninstalling > unplugging the usb > plugging the usb back in > and hitting update drivers and browsing to the file where the drivers are? Jun 18 '19 at 12:48
  • @majenko I tried reinstalling the drivers before I came here. I just figured there was a quick fix to fixing a broken sketch. I wrote my OP hastily and can update it if needed Jun 18 '19 at 13:06
1

This very much looks like the Serial-over-USB-Driver has chosen another port than COM5 on reconnecting the board. Assuming you are using the Arduino IDE, check whether COM5 still shows up in the Board -> Port menu -- or, in other words, go there and select the port that is listed there while the board is plugged in.

Usually, I'd expect this port to be COM3 on Windows, but that may change when you...

  • physically disconnect and reconnect the board too fast (i.e. the driver has not yet shut down the old COM port when a "new device on USB!" event comes in)
  • still have the Serial Monitor open when disconnecting and reconnecting (because the driver cannot remove the virtual COM port device while the Serial Monitor has it opened, in which case the driver creates another virtual COM port device on a different number)
  • disconnect and reconnect while the esptool process is still working (same reason as above).

It also might help to enable verbose output for compiling and uploading (see preferences dialog in Arduino IDE).

11
  • thank you for this throrough reply. The com5 port (the one i have always used) shows up when i plug in the programmer board without the esp32 cam board attached. However if I attach the esp32 cam board to the programmer (the same way i had it wired all times before) the com port disappears and the USB is not recognized by windows. Could it be that the programmer is stuck trying to program and needs to be reset somehow? Jun 18 '19 at 16:30
  • Hi, what do you think is going on? Jun 18 '19 at 18:48
  • 1
    "the programmer is stuck trying to program" - if you power cycle (i.e. disconnect from power) the "programmer" has no memory of what it was doing before. At a guess, you've "fried" and probably permanently destroyed something Jun 19 '19 at 4:10
  • @DavidGraff This sounds more like that the cam board produces a short, rendering the programmer inoperable. Either you have created a solder bridge or something like that (e.g. between Vcc and GND) on the cam board, or your esp32 is fried (did it come into contact with 5V?) and shorts internally. (On a completely different note: your name sounds familiar. Does TUDO tell you anything?)
    – orithena
    Jun 19 '19 at 8:47
  • @orithena no that doesnt ring a bell. So it is likely I fired both boards when uploading the sketch and then providing 5v via the 5v input on the esp32 cam board? I have tried all options to reset the board. Jun 19 '19 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.