0

last two days I am trying to program my blue pill with Arduino IDE, helplessly... Actually, I managed to install simple blink program, but after that, all other attempts ended up with:

Failed to init device.
stm32flash Arduino_STM32_0.9

http://github.com/rogerclarkmelbourne/arduino_stm32

Using Parser : Raw BINARY
Interface serial_posix: 115200 8E1

An error occurred while uploading the sketch

I crawled internet but no help so far... I followed simply tutorial: https://www.youtube.com/watch?v=K-jYSysmw9w just as this https://github.com/rogerclarkmelbourne/Arduino_STM32/wiki/Installation, and as I said, first time was problem but finally successfully upload it. However, after that when I wanted some real working program to install failed. All mappings ftdi -> stm32 are correct, jumper booto is set to 1 mode, for programming, I have required files within /etc/udev/rules.d, stm32 library folder in sketch folder, and yet the error above is happening for a last 20 hours... (I am using Ubuntu 16.04) Please, if anyone point me what is wrong (why first time worked and second wont), or to give me precise steps to perform in order to work, I appreciate.

EDIT: Blinking program works just fine when I move jumper to 0, and supply power via usb.

migrated from electronics.stackexchange.com Jun 18 at 10:50

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

  • Rewind to where you had some success. Do you still have that same success? – Andy aka Jun 18 at 9:43
  • I did... Clean up and delete everything, and started from scratch. But nothing, really frustrating... FTDI red led is on, stm32 red led is on, but when I do upload, the same error, over and over again.. stm32flash Arduino_STM32_0.9 github.com/rogerclarkmelbourne/arduino_stm32 Using Parser : Raw BINARY Interface serial_posix: 115200 8E1 Failed to init device. – Creator Jun 18 at 9:48
0

thanx for help... It turns out that I have been sold crappy additional pins to plugin into breadboard. Even STM32 blink, turns out that one of the tx/rx has no contact with board (probably for microns). However, firmed them altogether without breadboard, and it works...I spent 15 hours with this issue...

  • I don't think additional pins are really crappy. It supposed to be soldered on the board. – KIIV Jun 18 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.