0

I am building a mini-cnc laser engraver as shown in this intructable and this youtube video.

I have built the circuit (minus the jst connector and two male pins at the top left of the board) and have attached a stepper motor from a dvd drive. It worked like a charm, but made a loud ringing noise (like tinnitus.) I proceeded to test it with laser GRBL, and it moved great, but gradually started missing steps, at first only in one direction and eventually in both. After a couple hours of being connected, it wouldn't budge at all. I switched the motor for another motor, and tested it again. This time the motor was much shorter-lived. It made 5 steps perfectly and then just shut off. You could hear the motor try to turn, but it was like it didn't have any torque at all. What could be the issue? (I also tried it on the other axis with the other motor driver, no change.)

It's also worth noting that at one point both the positive and negative (ground) cables from my power supply made contact with metal at once, throwing a spark. However, the steps were already beginning to be lost before that happened.

As per your request, I have attached the circuit layout I am attempting (it's identical to the one in the tutorial) as well as a picture of my physical circuit board. (sorry, a link was my only option as the pics were to big for upload) I know the soldering is pretty bad- I have a giant soldering iron. I don't see any shorts though.

Intended Layout

  • 1
    At what voltage did you run those steppers? – Gerben Jun 11 at 13:23
  • @Gerben im going to be completely honest, ive never attempted anything with circuit boards or arduino before. I followed the instructables, which tells me to use a 12v power supply on the screw terminal after everything is hooked up. – Drake Ford just now Edit Delete – Drake Ford Jun 11 at 22:26
  • 1
    Your steppers might be 5V instead of 12V. Or his are 5Volt to, but has set the A4988 Motor Drivers to limit the current (with the small potentiometer on the board). – Gerben Jun 12 at 9:37
  • 1
    To progress this further I think you'd need to edit your answer to add the part number(s) of your components (preferably along with with their specifications) and along with the schematic / circuit layout you have implemented (rather than the one from the tutorial). – AJP Jun 13 at 8:56
  • 1
    You can upload images as part of your question, you know. That is far preferable to sending people off-site to some link that might go down in a year, making the question hard to follow. I also don't see the part numbers that were requested. – Nick Gammon Jun 15 at 5:07
0

So the problem was that somehow the potentiometer had reset its own vref output. I couldn't adjust it after it did this. I replaced both drivers and it works like a charm now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.