0

enter image description herelet me describe my schema, i got one arduino and one esp32 connected over i2c using 30m cat 5e ftp cable, I'm using 12v to power up both devices, each of them have dc-dc converter that convert to 5V, there is two P82B715P extenders, controllers i2c bus is wired with 10K pullups to P82B715P , i2c bus between P82B715P is wired with 1K pullups on master device side. On 30M cable it works only if I transmit SDA, SCL in twister pair with ground, no power voltage (+12V) is on the cable. When I place +12V on the cable, I2C bus stop working, tried to decrease pullups to 0.4K no effect, since I do not understand can only make try/fail tests. Question is do I need to adjust pullups beween P82B715P only, or I need to change pullups between P82B715P and esp/arduino? Perhaps for calculation of pullups I must mention that i2c bus work on 10KHz

enter image description here

  • Can you post a schematic? Your question is a little hard to understand. Help us to help you. :) – Nick Gammon Jun 10 at 7:36
  • Well I do not have schematic, gonna try to draw one later – user3503519 Jun 10 at 8:05
  • Check VCC and pullup calculation. ti.com/lit/ds/symlink/p82b715.pdf – Mikael Patel Jun 10 at 11:07
  • Using the formula and the remark in the datasheet (8.1.1), I get between 330 and 660 Ohm for the 30m cable. Are you getting a stable 5V on the otherside of the cat5 cable; from the dc-dc converter? – Gerben Jun 10 at 12:43
  • yes voltage is stable, just I2c not working if +12V is on same cable where data is. – user3503519 Jun 10 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.