0

I'm trying to connect a Bluetooth serial stream from a Teensy3.2 to an Ubuntu laptop. The USB comms between the Teensy and the laptop work fine and the BT comms between the Teensy and my phone work fine. But I can't yet connect to the Bluetooth from my laptop. (I want this because I want to eliminate the USB cable eventually).

I'm using Teensy3.2, Ubuntu 18.04, Bluetooth HC-06.

I tried the Ubuntu settings app and it can see the BT module but when I click pair it seems to use a different procedure than the BT module expects, it gives a 6 digit number instead of accepting a 4 digit pin.

I tried to follow these instructions. The hcitool scan command lists the BT module so the laptop can see it. The sudo rfcomm bind rfcomm0 command does not return, just seems to hang. Same for the sudo rfcomm release rfcomm0.

I also tried to use the rfcomm command without the /etc/bluetooth/rfcomm.conf file, sudo rfcomm bind rfcomm0 xx:xx:xx:xx:xx:xx 1. Same results, it just hangs.

Any suggestions please?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.