0

I have an ESP8266-12E, I used it previously and it worked fine (approx 2 years ago)

I can't seem to get it to detect WiFi networks or appear as an Access Point

I can upload the blink sketch and the onboard LED will work correctly and the serial monitor will show output from the ESP8266, but there appears to be no WiFi functionality

I have tried using previous versions of the ESP core board definition via the Arduino board manager

I have tried using an external power supply (wall plug) rather than the powering from a USB port

I have tried erasing the flash using esptool.py

I have checked that the WiFi router I am trying to connect to is operating at 2.4Ghz (also there are other WiFi networks around and I set up a second router to make sure)

I have tried connecting to the Access Point using the SSID (with and without a password) despite it not appearing

I have tried getting it to connect to an Access Point even though none are found

Is there something I am missing or should I order a new module?

Any other suggestions please!

Output when uploading a sketch

    esptool.py v2.6
    Serial port /dev/cu.SLAB_USBtoUART
    Connecting........_
    Chip is ESP8266EX
    Features: WiFi
    MAC: a0:20:a6:12:51:46
    Uploading stub...
    Running stub...
    Stub running...
    Erasing flash (this may take a while)...
    Chip erase completed successfully in 9.0s
    Hard resetting via RTS pin...
    esptool.py v2.6
    Serial port /dev/cu.SLAB_USBtoUART
    Connecting........_
    Chip is ESP8266EX
    Features: WiFi
    MAC: a0:20:a6:12:54:54
    Uploading stub...
    Running stub...
    Stub running...
    Configuring flash size...
    Auto-detected Flash size: 4MB
    Compressed 293920 bytes to 210833...

    Writing at 0x00000000... (7 %)
    Writing at 0x00004000... (15 %)
    Writing at 0x00008000... (23 %)
    Writing at 0x0000c000... (30 %)
    Writing at 0x00010000... (38 %)
    Writing at 0x00014000... (46 %)
    Writing at 0x00018000... (53 %)
    Writing at 0x0001c000... (61 %)
    Writing at 0x00020000... (69 %)
    Writing at 0x00024000... (76 %)
    Writing at 0x00028000... (84 %)
    Writing at 0x0002c000... (92 %)
    Writing at 0x00030000... (100 %)
    Wrote 293920 bytes (210833 compressed) at 0x00000000 in 18.6 seconds (effective 126.4 kbit/s)...
    Hash of data verified.

    Leaving...
    Hard resetting via RTS pin...
  • try the AT firmware – Juraj May 25 at 13:03
  • I tried downloading the default firmware from nodemcu-build.com and flashed it. Is this the one you mean? – Melvin May 25 at 13:04
  • Lua firmware? no. and does it work – Juraj May 25 at 13:11
  • I got an output saying the version of the Lua firmware and it could not init but I didn't try any AT commands... trying to find the AT firmware currently – Melvin May 25 at 13:15
  • espressif.com/en/support/download/… use 1.6.2. instructions: espressif.com/sites/default/files/documentation/… chapter 1.2.2. – Juraj May 25 at 13:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.