1

Recently I bought this wifi adapter for my IOT projects that I connected to my arduino uno that seems to not working. I have tried with the arduino ESP8266WiFi library with RX connected to pin 0 and TX connected to pin 1 I have also tried the softwareSerial and still the same result that is, in the serial monitor i always get "error" or I get nothing Thank you in advance and sorry if I made a mistake in the post, I am new to StackExchange :)

edit (added code to question):

#include <SoftwareSerial.h>

SoftwareSerial ESPSerial(10, 11); // RX, TX

void setup() {
  // Open serial communications
  Serial.begin(115200);
  // set the data rate for the SoftwareSerial port
  // if this doesnt work you for you then try different baud rate
  ESPSerial.begin(115200);
  ESPSerial.println("Ready to take AT commands");
}

void loop() { // run over and over
  if (ESPSerial.available()) {
    // reads input from serial console and writes to esp8266
    Serial.write(ESPSerial.read());
  }
  if (Serial.available()) {
    // reads input from esp8266 and writes to serial console
    ESPSerial.write(Serial.read());
  }
}

Esp adapter

error

3
  • 1
    Please add your source code as text to your post and what is your expected output? Also please tell us for which board the shown code is. May 20 '19 at 11:29
  • did you set in Serial Monitor the line ends?
    – Juraj
    May 20 '19 at 17:54
  • 1
    @TarickWelling I am using arduino uno and I was expecting to enter some at commands. May 21 '19 at 18:13
0

gpo0 goes to ground to program the module

1
  • 2
    Care to expand on that a little? How would you suggest that is done given the adaptor? Where is GPIO 0? What else needs doing to enter programming mode?
    – Majenko
    May 16 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.