0

I had my sketch uplaoded and everything was working fine when I tried connecting one of the input pins(pre-configured as digital INPUT) to 12V, just to see if this was being read as a HIGH as well. It seems to have done something and the board stopped working. Moreover, all pins seem to be stuck at HIGH!

So far Ive tried the following:

  • reset button: doesnt help
  • re-upload: doesn't work - it says not in sync

Physically nothing seems to be burnt/blown. What am I missing? Have I fried my board? I hope not. PS: It was connected to a 12V external power source

Any thoughts?

  • 1
    If you have an Uno with the ATMega328 in a socket, you could just replace the chip with a new one (with bootloader pre-programmed). If it's the SMD version, you're out of luck (unless you have a friend that does SMD soldering). – Gerben Dec 18 '14 at 16:02
  • @Gerben :That seems like a good option, do you know where I can get a bootloader programmed ATMega328? – Ameya Dec 18 '14 at 19:05
  • @Gerben : Do you know where I can get a bootloader programmed ATMega 328? I think i can replace it, luckily my board came with an IC socket. – Ameya Dec 18 '14 at 19:07
  • I don't know where you live. But try stores that also sell regular arduino's. E.g. Sparkfun sells them. – Gerben Dec 19 '14 at 15:29
  • 1
    @Gerben Thanks Gerben. I found some for a good price on Amazon. Thank God for Amazon! :-) – Ameya Dec 20 '14 at 0:02
1

Unfortunately, the arduino's input pins are not tolerant of 12 volts, You have likely caused permanent damage to the chip =(. There is a regulator that makes it capable of being powered by 12 volts, but the input pins are different.

If you look at table 30-1 on the datasheet for the Uno's controller here you can see the input characteristics. The arduino is powered at 5v, so the max digital input voltage is 5.5v

  • Thats good to know. I assumed they could take anything up to 20V!(as rather silly assumption. Looks like I will have to use a voltage divider to sample the input voltage and get it under 5V for my use. Thanks Brett! – Ameya Dec 18 '14 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.