I was testing and debugging a code I wrote for a robot with 3 stepper motors on (Arduino Uno + CNCShield V3 + a4988 stepper drivers). I want to disable drivers at will. so I bypassed EN pin on 2 of a4988s to pin12 and pin13 of Arduino. (by defalut all EN pins of drivers are are connected to pin8 ) everything was ok but suddenly the Reset button is not working and I can't upload new codes to Arduino! I get this error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x83
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x83
Problem uploading to board. 

but Arduino still is working with the last code that was uploaded to it!!! have I fried my Arduino? and Why is this happening?enter image description here

  • 1
    Quick thought: Did you try a different COM port on your computer. (It may not be an Arduino problem at all.) If your OS is Linux try "lsusb" to see where the Arduno is connected. If Windows there are utilities you can install to see better what USB devices are connected.
    – st2000
    Commented May 17, 2019 at 13:12
  • I tested another Arduino Uno with my code and computer (windows 10) . It was OK. Somethings are wrong with my new wiring (pin 12 @ 13). I'm afraid It will fry the other board too.
    – 2012User
    Commented May 17, 2019 at 13:29

1 Answer 1


Try manually resetting the board:

  • Before uploading, run Verify.
  • Hold the reset button and click Upload.
  • Release the reset button.

If that worked, your board's reset isn't fried, it just isn't receiving a reset via the serial cable. If it failed, either part of the board or MCU may be damaged; something attached to the board may be inhibiting the reset signal; or the software may have disabled the board's reset pin. In the latter case, see the Arduino StackExchange article, How do I repurpose Arduino's reset button, for how this can happen and how to undo it if it has.

Is here anything wrong with using pins 12 and 13?

I'm not familiar with stepper driver, but at a quick glance at its data sheet, and it's logic being 3.3v & 5 v compatible, I don't see any problem with connecting any of its logic to any of Arduino's logic pins (almost all of them). Since the driver also has a motor drive-voltage input for driving your motors, accidentally connecting an Arduino pin to a driver pin (or anything else) carrying the drive-voltage could - probably would - damage at least the connected pin driver in the MCU, and possibly other parts of it as well.

If your Arduino has a socketed Atmega chip, and since you already know another Arduino works as you expect it to, replacing the Atmega chip will be the quickest, cheapest & easiest fix. Just go over your wiring and make sure no motor drive voltages are connected to the Arduino board.

  • I tried it. Holding reset button didn't work. Is here anything wrong with using pins 12 and 13? I guess this is what made my Uno fry!
    – 2012User
    Commented May 17, 2019 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.