0

I am using an Arduino UNO which worked fine until today. My system: Ubuntu 18.04

Now, the IDE can no longer connect to it:

  • Cannot do any sketch upload
  • Cannot ask for board info
  • No USB ports shown in tools --> port (only 2 serial ports shown)
  • ttyyACM0 not showing up in /dev

However, both lsusb and dmesg show that the board is recognized somehow.

lsusb output:

Bus 001 Device 012: ID 03eb:2fef Atmel Corp.

dmesg output:

[ 2922.171042] usb 1-1.3: new full-speed USB device number 12 using ehci-pci
[ 2922.282047] usb 1-1.3: New USB device found, idVendor=03eb, idProduct=2fef
[ 2922.282052] usb 1-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0

The problem is the same on 2 different computers, which leads me to suspect that there is something wrong with the board. Is it possible that a board be shown by both dmesg and lsusb and still be malfunctioning ?

  • problem with 16u2 firmware? – Juraj May 10 at 5:03
1

The board was bad. I just replaced it and it now works.

So, to answer my own question, an Arduino board can show up on lsusb and dmesg and yet be faulty. This is what the dmesg output is for a healthy board:

[10492.388028] usb 1-1.4: new full-speed USB device number 13 using ehci-pci
[10492.500520] usb 1-1.4: New USB device found, idVendor=2341, idProduct=0043
[10492.500526] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[10492.500529] usb 1-1.4: Manufacturer: Arduino (www.arduino.cc)
[10492.500533] usb 1-1.4: SerialNumber: 55736323739351010292
[10492.520354] cdc_acm 1-1.4:1.0: ttyACM0: USB ACM device
[10492.520832] usbcore: registered new interface driver cdc_acm
[10492.520835] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

And here is the lsusb output:

Bus 001 Device 013: ID 2341:0043 Arduino SA Uno R3 (CDC ACM)

Judging on the difference with the previous outputs from both commands (when the faulty board was connected), it seems that my board had reverted to the basic Atmel USB interface and that the Arduino specific USB handshake was not working. Can anyone confirm ?

  • the USB interface on Uno is an ATmega 8u4 or 16u4. it is an AVR MCU with native USB port programmed to send data to the main MCU of the board (328p). if the firmware in 16u4 is corrupted the native USB port connects but the virtual serial port is not created arduino.cc/en/Hacking/DFUProgramming8U2 – Juraj May 10 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.