0

When I start the arduino IDE as regular user from my debian testing system, I get a crash right after the splash screen:

Temp/arduino-1.8.9/arduino                                                              :)
Picked up JAVA_TOOL_OPTIONS: 
java.lang.NullPointerException
        at processing.app.BaseNoGui.onBoardOrPortChange(BaseNoGui.java:679)
        at processing.app.Base.onBoardOrPortChange(Base.java:1317)
        at processing.app.Base$12.actionPerformed(Base.java:1544)
        at processing.app.Base.rebuildBoardsMenu(Base.java:1494)
        at processing.app.Base.<init>(Base.java:275)
        at processing.app.Base.main(Base.java:151)
Temp/arduino-1.8.9/arduino  7,28s user 0,50s system 183% cpu 4,243 total

When I start it with sudo I can use everything regularly. There are quite a few bug reports mainly in the archlinux community about a similar issue, where they suggest to install a package arduino-avr-core to solve it. But I assume, the reason why it happens for me, is different, since it runs fine with root privileges, and we do not have such a package in debian. Debians arduino IDE from the repos is way to old to use it these days with modern boards.

My Groups: tty uucp dialout cdrom floppy sudo audio dip video plugdev systemd-journal netdev bluetooth lpadmin scanner docker

The file permissions are fine for the ide and the arduino data directory.

The permissions for the usb device are also correct, just in case:crw-rw----+ 1 root dialout 188, 0 Mai 4 11:42 /dev/ttyUSB0

My Java environment:

java --version                                                                          :)
openjdk 11.0.3 2019-04-16
OpenJDK Runtime Environment (build 11.0.3+1-Debian-1)
OpenJDK 64-Bit Server VM (build 11.0.3+1-Debian-1, mixed mode, sharing)

Maybe someone ran into the same problem as well?

  • If you ran with sudo then your Arduino data directory may be locked to your user. Try deleting it. sudo rm -rf .arduino15 when in your home directory. I am just installing a VM of debian testing to check it out. – Majenko May 4 at 11:28
  • Looking at how it runs with sudo under debain - when run with sudo it uses root's .arduino15. When run as the user it uses the user's .arduino15. So it could just be that your .arduino15 directory is screwed and deleting it will fix it. – Majenko May 4 at 12:45
  • Wow... it turned out, that I was not aware of the existence of ~/.arduino15. I tried to delete the ~/Arduino and ~/.arduino direcory several times, but to no avail. Deleting ~/.arduino15 indeed fixed the issue. – darkmattercoder May 4 at 16:35
  • IDE version 1.5.0 changed the data directory from .arduino to .arduino15 - I guess there were changes in the content formatting for that version, and they wanted to protect earlier versions. – Majenko May 4 at 16:36
1

It turned out, that the current Arduino IDE is using a directory ~/.arduino15 for data. I was not aware of the existence of it. The comments to my question made that clear. I tried to delete the ~/Arduino and ~/.arduino direcory several times, but to no avail. Deleting ~/.arduino15 indeed fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.