1

I followed this tutorial for a demo code for the SR04 ultrasonic distance sensor (without the LCD display). I've installed the Arduino IDE and wrote the code in it and saved it in some location. Compilation of the code is successful. However when I try to upload the code, I get the message:

Invalid library found in C:\Users\Dame\Documents\Arduino\libraries\arduino_144469: no headers files (.h) found in C:\Users\Dame\Documents\Arduino\libraries\arduino_144469

There are no header files in the directory and I'm wondering if I need to download additional header files or if I should configure something else.

5
  • Is there anything in that folder?
    – chrisl
    May 3 '19 at 10:24
  • No. It is empty. May 3 '19 at 10:40
  • Then delete it. The Arduino IDE tries to find a library there, because it is a folder in the library folder.
    – chrisl
    May 3 '19 at 10:42
  • It worked. Thanks. I can't believe all it took was deleting. I looked all over the internet for a solution. May 3 '19 at 10:52
  • Yes! Exactly the answer I was looking for. Worked perfectly. Thanks Guys. :)
    – Dan
    Oct 23 '19 at 0:26
2

If the folder is not needed then delete it.

The Arduino IDE uses the folders in the library folder to search for library header files (ie. .h files). It expects one library in each folder. When it see's a folder without any header files in it, it will count this as an invalid library.

0

i had similar problem and I Fix it by changing in preferences field Sketchbook location to different drive (from c:\ to d:).

This problem can ocure on system windows 10 (probably also 8) where you have sequred drive with system installed to protect you data (or system files) against some unwanted changes. Probably there is missing in Arduino some rights to make directory and save files in temporary directories, but i'm not an expert.

Not the answer you're looking for? Browse other questions tagged or ask your own question.