0

I previously read a few guides and tutorials about the ESP8266 and i just started using the ESP-12F module as i think that it is a terrific replacement for Arduino with the added benefit of Wi-Fi. I only have the module itself which is basically a metal casing so, i wired up the ESP-12F module according to this schematic.ESP-12 module wire connections

My USB-TTL board is operating at 3 V for its VCC and also for the TX and RX logic levels. I use Arduino IDE 1.8.9 (i made sure that i am using the latest stable version) and then set the COM port to the USB-TTL RS232 connected to the ESP12F and typed "AT" and got a response "OK". Then, i tried, "AT+RST" and got a big bunch of text which proved that there is successful communication with the ESP module. But then, i tried to connect the ESP-12F to my Wi-Fi network, so i entered: AT+CWJAP_CUR="SSID","password" replacing the SSID and password with my own and it gave the response "ERROR", so i tried the old format AT+CWJAP="SSID","password" and again i got "ERROR". So, what am i doing wrong? How to fix this? I was thinking that maybe the firmware on my ESP is old and needs to be updated, so i entered "AT+GMR" and i got this info:

19:07:27.560 -> ready
19:07:27.560 -> AT+GMR
19:07:27.560 -> AT version:1.2.0.0(Jul  1 2016 20:04:45)
19:07:27.560 -> SDK version:1.5.4.1(39cb9a32)
19:07:27.560 -> Ai-Thinker Technology Co. Ltd.
19:07:27.560 -> Dec  2 2016 14:21:16
19:07:27.560 -> OK

Do i need to update my module to be able to connect it to my Wi-Fi? If yes, how? I want to update it as safely as possible as this is my only ESP module and i don't want to inadvertently damage it.

  • Try AT+CWMODE=1 first to put it into STA mode. – Majenko Apr 23 at 17:14
  • I did as you said and it worked! Thanks for the help. I will keep digging into the Espressif AT commands datasheet to learn more. By the way, is it advisable to update the firmware at this point? – WiredMaker Apr 23 at 17:22
  • Personally I never use the AT firmware. I always program the ESP8266 directly from the Arduino IDE (well, from UECIDE actually, but the principle is the same). – Majenko Apr 23 at 17:28
  • AT+CIUPDATE after you connected it to Internet – Juraj Apr 23 at 18:15
1

You can't connect to an access point until you put the module into Station mode.

AT+CWMODE=1

That will put it in STA mode. You can alternatively make it an access point (AP mode) with:

AP+CWMODE=2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.