0

I'm currently trying to control a brushless DC motor (EMAX 1806-2280Kv) with a ESC called Wasabi Eco 12A (Wasabi Eco specifications#1 , Wasabi Eco specifications#2)

I'm trying to control the motor via an Arduino Uno, and using their IDE to begin with. I have the following code:

#include <Servo.h>
Servo ESC;     // create servo object to control the ESC
void setup() {
  delay(1000);
  ESC.attach(9, 1000, 2000); // (pin, min pulse width, max pulse width in microseconds) 
  delay(2000);
   ESC.write(180);
  delay(300);
  ESC.write(0);
  delay(2000);

}

void loop() {

  ESC.write(1800);    // Send the signal to the ESC
  delay(100);
}

I have tried various of combinations and non of them seems to work. The motor sometimes beeps, but not in the correct way. I have tried to look for the PPM width (which is 1000 - 2000 μS in the code) but can't seem to find it anywhere. Any suggestions of what I'm doing wrong?

migrated from electronics.stackexchange.com Apr 16 at 1:07

This question came from our site for electronics and electrical engineering professionals, students, and enthusiasts.

  • Probably you do not have the correct arming sequence. If your question is about probing you need to explain what you tried. – Chris Stratton Apr 15 at 18:09
  • I did as the datasheet said; full throttle and then minimum. But nothing seems to happen – Emil Møller Ringgaard Apr 15 at 18:19
  • This is really buried in the details of things you have not documented, but you could check if your "ESC" library requires that you set the pin as an output first. – Chris Stratton Apr 15 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy