0

I'm trying to use an atmega chip from an arduino on a breadboard, with minimal hardware (using the internal 8mhz clock). I am using the article in the link provided. When I reach the final step (burning the bootloader), I get an error telling me the device signature is wrong-

Arduino: 1.8.5 (Windows 10), Board: "ATmega328 on a breadboard (8 MHz internal clock)"

avrdude: Yikes! Invalid device signature. Double check connections and try again, or use -F to override this check.

Error while burning bootloader.

I am assuming the error is because the chip is from a uno clone, and uses an atmega328p-pu chip. How am I able to override this check using -F, as described in the error message? Or is there maybe some other way i can fix this? Thanks in advance.

https://www.arduino.cc/en/Tutorial/ArduinoToBreadboard

0

One of the parameters that you have to give avrdude is the microcontroller you are using, and then it checks the signature of the micro to ensuere that everthing is ok. this parameter is passed through -p flag

avrdude -p <microcontroller name>

For ATmega328 this parameter should be m328 and in your case, with ATmega328p this parameter should be m328p. All options avalible can be checked in man page.

  • Ok thanks. How do I access and change the flag? – Steve Apr 11 at 13:07
  • If you are using Arduino IDE to load micro, you will have to select what micro you are using in Tools > Board Menu or something like this. Anyway you can use terminal also. – tarekasis Apr 11 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy